Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74335 - [linux][linux-zen] iwlwifi not working on kernel 5.17.1

Attached to Project: Arch Linux
Opened by Borislav Gerassimov (slimmer) - Monday, 04 April 2022, 07:00 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 05 April 2022, 06:42 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Module iwlwifi doesn't load/work on kernel 5.17.1. I suspect some connection to changes in iwlmei module, because in dmesg there are errors like these (there are 5-6 more with just different symbol name):

iwlmei: Unknown symbol mei_cldev_disable (err -2)
iwlmei: Unknown symbol mei_cldev_dma_map (err -2)
iwlmei: Unknown symbol mei_cldev_dma_unmap (err -2)
iwlmei: Unknown symbol mei_cldev_recv (err -2)

The machine is an AMD Ryzen 7 5800-based laptop (Lenovo "14ACH5") with installed "Intel Corporation Wireless 8265 / 8275 (rev 78)" because the factory Realtek doesn't work as well with linux. So... there is no Intel Management Engine at all which iwlmei is for. I tried blacklisting the iwlmei module, but then there's this:

kernel: iwlwifi: Unknown symbol iwl_mei_is_connected (err -2)

So... back to linux-hardened 5.16.18 for now...

Additional info:
linux{,-zen}-5.17.1
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 05 April 2022, 06:42 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Monday, 04 April 2022, 14:08 GMT
You didn't blacklist mei, I assume? I guess `modprobe mei` also fails.
Comment by Borislav Gerassimov (slimmer) - Monday, 04 April 2022, 14:57 GMT
lsmod shows no mei in both 5.16 and 5.17 and nothing about it in dmesg. I'll try it later.
Comment by Borislav Gerassimov (slimmer) - Tuesday, 05 April 2022, 06:40 GMT
That's my fault. Turns out that some time ago I have blacklisted some watchdogs and mei modules. After removing this from modprobe.d everything is working fine. I'm sorry for bothering you. Consider this solved.

Loading...