Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74292 - [parallel] Cannot source env_parallel.fish in fish 3.4.1

Attached to Project: Community Packages
Opened by Steve Ward (planet36) - Thursday, 31 March 2022, 22:20 GMT
Last edited by Toolybird (Toolybird) - Saturday, 30 July 2022, 21:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To George Rawlinson (rawlinsong)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Cannot source env_parallel.fish in fish 3.4.1


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
fish 3.4.1
parallel 20220322

Steps to reproduce:
In an interactive fish shell, run
$ source (which env_parallel.fish)

The command fails with exit status 1 and prints something like this:

/usr/bin/env_parallel.fish (line 59): Invalid token '(
...
from sourcing file /usr/bin/env_parallel.fish
source: Error while reading file “/usr/bin/env_parallel.fish”
This task depends upon

Closed by  Toolybird (Toolybird)
Saturday, 30 July 2022, 21:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  fish 3.5.1-1
Comment by Steve Ward (planet36) - Friday, 01 April 2022, 00:38 GMT
The summary should be "Cannot source env_parallel.fish in fish 3.4.1".

I didn't see the field because Dark Reader made it low contrast.
Comment by Steve Ward (planet36) - Saturday, 30 July 2022, 02:35 GMT

Loading...