Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74282 - [gnome-shell] gnome-extensions-app segfaults

Attached to Project: Arch Linux
Opened by Simon Perry (pezz) - Wednesday, 30 March 2022, 21:11 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 06 April 2022, 21:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
gnome-extensions-app segfaults now for some reason, which extensions are installed doesn't seem to matter.

Additional info:
* package version(s)
gnome-shell 1:41.5-1

Steps to reproduce:
% gnome-extensions-app
/usr/bin/gnome-extensions-app: line 2: 7726 Segmentation fault (core dumped) /usr/bin/gjs /usr/share/gnome-shell/org.gnome.Extensions "$@"

Workaround:
I found some older info on Google, this allows it to work:
% GSK_RENDERER=cairo gnome-extensions-app
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 06 April 2022, 21:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  mesa 22.0.1-3
Comment by Francesco Di Nardo (angelsoul) - Thursday, 31 March 2022, 22:29 GMT
Hi, I am facing the same issue, and I tried different applications running on gtk4. All of them are not working, exiting with "Segmentation Fault" error.
I think this is not strictly related to the gnome-extenstion-app but to gtk4 in general.
I used your workaround as well, and I am able to open the extension app, but I still can't go into the extension settings.

Also it seems to be an issue with Xorg only. If I run gnome-shell in wayland it works without changing the GSK_RENDERER variable.
see this: https://bugs.archlinux.org/task/74294
Comment by Jan Alexander Steffens (heftig) - Friday, 01 April 2022, 15:18 GMT
I can't reproduce this. Please provide backtraces.
Comment by Jan Alexander Steffens (heftig) - Friday, 01 April 2022, 15:23 GMT
Never mind; got it to crash. It crashes in the DRI driver so no idea where the problem is.
Comment by Jan Alexander Steffens (heftig) - Wednesday, 06 April 2022, 21:03 GMT
Was this fixed with mesa 22.0.1-3?
Comment by Simon Perry (pezz) - Wednesday, 06 April 2022, 21:12 GMT
Apologies, I didn't realise mesa was a potential fix for this but yes - gnome-extensions-app runs correctly now!

Cheers.

Loading...