Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7426 - Remove debug output from taglib.

Attached to Project: Arch Linux
Opened by Sander Jansen (GogglesGuy) - Tuesday, 12 June 2007, 03:51 GMT
Last edited by Jan de Groot (JGC) - Thursday, 14 June 2007, 06:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Damir Perisa (damir.perisa)
Architecture All
Severity Very Low
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

By default taglib is compiled to print out debug information to std:err/out. When reading files it may print out warnings like this:

TagLib: MPEG::Header::parse() -- Invalid sample rate.
TagLib: String::prepare() - Invalid UTF16 string.

IMHO libraries should never print out to the terminal, neither GUI apps which may use these libraries.

Please use --disable-debug on the ./configure command line to disable this.

This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 14 June 2007, 06:08 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Wednesday, 13 June 2007, 16:52 GMT
Why shouldn't it print these warnings/errors to terminal? It's completely normal for any application and gives you information about why your files are not working as they should. If it would be spewing verbose information about every action, it would be a bug, otherwise it's completely standard behavior.
Comment by Sander Jansen (GogglesGuy) - Thursday, 14 June 2007, 02:50 GMT
First of all, we're not talking about an application. We're talking about a library. Libraries shouldn't just print out information to the terminal since it is not garanteed that you will actually see it (and just because kde or gnome apps have habit of doing that doesn't it make correct).

Only when compiled for debug, they should print out asserts or other warnings that may be useful for developers. As a end user you're not interested in those warnings. Warnings or errors the user should see, should be passed to the application. Let the application decide whether to display it on the terminal or in some other way.

Now in case of tag lib the debug information printed out is not very useful for the end user anyway, since you have no idea which file it is referring too. Of course if you only open one file with tag lib, you may know, but if the application is scanning your whole harddrive you don't know because scanning a couple of 100 files goes very quickly. Also when you read in a lot of files, printing stuff out to a slow terminal will slow things down as well.

Anyway lots of reasons to disable debug output. (and might I add that even taglib considers this debug output).

Loading...