Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74259 - [nautilus] [samba] Unable to connect to samba shares with samba/smbclient 4.16.0

Attached to Project: Arch Linux
Opened by Nicolas Jeker (mnme) - Monday, 28 March 2022, 12:40 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 27 April 2022, 22:41 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 27
Private No

Details

After upgrading samba/smbclient from 4.15.6 to 4.16, I can't connect to samba shares with nautilus.

See this forum thread (not mine) for more information: https://bbs.archlinux.org/viewtopic.php?id=275179

Upstream bug reports:
https://gitlab.gnome.org/GNOME/gvfs/-/issues/611
https://bugzilla.redhat.com/show_bug.cgi?id=2068976
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 27 April 2022, 22:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  gvfs-smb 1.50.1, smbclient 4.16.0-6
Comment by Ghislain BERNARD (gbernard) - Monday, 28 March 2022, 15:45 GMT
Hi,

Same problem with Xfce 4.16.0-2, gvfs 1.50.0-1, gvfs-smb 1.50.0-1 and smbclient 4.16.0-2 from thunar 4.16.10-1.
Revert to smbclient 4.15.6-1 fixed the problem.

$ sudo pacman -Ss smbclient
extra/smbclient 4.16.0-2 [installed: 4.15.6-1]
Tools to access a server's filespace and printers via SMB

Best regards.
Comment by Nicolas Jeker (mnme) - Tuesday, 29 March 2022, 07:29 GMT
In this case, this should probably be moved from nautilus to gvfs-smb
Comment by Ruben Kelevra (RubenKelevra) - Tuesday, 29 March 2022, 15:46 GMT
Agreed. Makes sense to push an update for gvfs-smb and make it incompatible with smbclient 4.16.0-2 and downgrade smbclient with an epoch upgrade.
Comment by Oscar Garcia (ogarcia) - Thursday, 31 March 2022, 07:34 GMT
As says [a comment in redhat bugtracker](https://bugzilla.redhat.com/show_bug.cgi?id=2068976#c5) the culprit is [this change](https://gitlab.com/samba-team/samba/-/commit/34771e1931587807d0395c7ac7f4be18654997f4). It may be possible to revert the change by patching the package until it is permanently fixed.
Comment by Heinrich Siebmanns (Harvey) - Thursday, 31 March 2022, 07:37 GMT
deleted - Oscar was faster :p
Comment by loqs (loqs) - Thursday, 31 March 2022, 08:49 GMT Comment by Oscar Garcia (ogarcia) - Thursday, 31 March 2022, 08:52 GMT
I do a PKGBUILD with the patch and confirm that it works well
Comment by Christian (offlinehoster) - Thursday, 31 March 2022, 19:36 GMT
Is this a bug of "archlinux" smbclient or something about Nautilus.

I also reported this issue to the Nautilus team https://gitlab.gnome.org/GNOME/nautilus/-/issues/2206 and got some confirmation from another Fedora 36 beta user, that he also runs into that issue. I can't confirm that there is "also" an issue with smbclient directly...currently it looks like Nautilus has some issues with smbclient >= 4.16.0

It's working fine with smbclient 4.15.5 and Nautilus 41.2
Comment by David Rosenstrauch (darose) - Thursday, 31 March 2022, 19:40 GMT
Not a nautilus issue - I experience the same thing with Thunar. The issue seems to be in smbclient and/or gvfs-smb.
Comment by Christian (offlinehoster) - Thursday, 31 March 2022, 19:53 GMT
My first impression was, maybe they got changed an argument for smbclient (something like a camelcase issue with for example -u vs. -U), which is used by nautilus. But with this information about Thunar is having similar problems with smbclient 4.16.0 it looks like, there is something broken on this side of the ocean :)
Comment by Christian (offlinehoster) - Friday, 01 April 2022, 06:16 GMT
My first impression was, maybe they got changed an argument for smbclient (something like a camelcase issue with for example -u vs. -U), which is used by nautilus. But with this information about Thunar is having similar problems with smbclient 4.16.0 it looks like, there is something broken on this side of the ocean :)
Comment by Martin Sand (sandstorm) - Saturday, 02 April 2022, 10:24 GMT
Confirmed the behavior in Nautilus as well.
Downgrading package smbclient (4.16.0-4 => 4.15.5-1) solved the issue temporarily.
Comment by Nicolas Jeker (mnme) - Monday, 04 April 2022, 07:36 GMT
I can confirm that reverting samba commit 34771e1931587807d0395c7ac7f4be18654997f4 fixes the issue for me.
Comment by Wouter (wouter2512) - Saturday, 09 April 2022, 13:28 GMT
Can confirm same issue also occurs with Nemo.

pacman -Q gvfs-smb smbclient nemo
gvfs-smb 1.50.0-1
smbclient 4.16.0-4
nemo 5.2.4-1

Downgrading smbclient and samba to 4.15.6-1 fixes the issues I have.

Related bug reports on samba:
https://bugzilla.samba.org/show_bug.cgi?id=14983
Comment by Oscar Garcia (ogarcia) - Monday, 11 April 2022, 13:03 GMT
I open a new bug with all info an fix in proper package: https://bugs.archlinux.org/task/74447
Comment by David Rosenstrauch (darose) - Wednesday, 13 April 2022, 21:57 GMT
Looks like this is now working with smbclient-4.16.0-4 and gvfs-smb-1.50.0+r5+g747c7f6e-1
Comment by Mark Blakeney (bulletmark) - Wednesday, 13 April 2022, 22:09 GMT
I updated today (which includes gvfs* 1.50.0+r5+g747c7f6e-1) and with smbclient 4.16.0-4 it still fails for me.
Comment by Heinrich Siebmanns (Harvey) - Thursday, 14 April 2022, 10:22 GMT
Works for me after pacman -Syuu (testing enabled). Had to restart gvfsd once with 'sudo killall gvfsd
' though.
Comment by Ghislain BERNARD (gbernard) - Thursday, 14 April 2022, 10:31 GMT
Fixed with last updated :
extra/gvfs-smb 1.50.0+r5+g747c7f6e-1 (gnome) [installed]
Virtual filesystem implementation for GIO (SMB/CIFS backend; Windows client)
Comment by Logan M. (lmm5247) - Friday, 15 April 2022, 15:22 GMT
Updated today (gvfs-smb 1.50.0+r5+g747c7f6e-1 and smbclient 4.16.0-4) and still not working for me. Had to downgrade to smbclient 4.15.6-1 to fix.
Comment by Wolfgang Hahn (Heinrich) - Saturday, 16 April 2022, 12:33 GMT
I cannot connect from my android phone (SMB2 or SMB3) to samba server with samba 4.16.0-4. The error message I get contains smb2_create and 3221225506. 4.15.6 works without problems. Any tips if this is perhaps only a configuration problem ?
Comment by Strangiato (Strangiato) - Sunday, 17 April 2022, 03:11 GMT
I use Arch on both server and client machines. Samba 4.15.6-1 stopped working (smb and nmb services do not start) after update to icu 71.1,
then I updated to samba 4.16.0-5 on the server and to smbclient 4.16.0-5 on the client and the problem reported here persists. gvfs-smb 1.50.0+r5+g747c7f6e-1 package is installed on the client.
Comment by Jan Alexander Steffens (heftig) - Tuesday, 26 April 2022, 21:35 GMT
Still an issue with gvfs-smb 1.50.1?
Comment by Mark Blakeney (bulletmark) - Tuesday, 26 April 2022, 22:06 GMT
Yes, still a problem for me on up-to-date Arch client PC. Nautilus returns "Failed to mount Windows share: Invalid argument". Server (Arch ARM) is running samba 4.16.0-5.1.
Comment by Daniel Wood (danwood76) - Wednesday, 27 April 2022, 09:58 GMT
I can confirm that this patch fixes the issue on my system:
https://gitlab.com/samba-team/samba/-/commit/34771e1931587807d0395c7ac7f4be18654997f4

Attached is my PKGBUILD tarball (modified from Oscar Garcia's version above)
Comment by Daniel Wood (danwood76) - Wednesday, 27 April 2022, 10:00 GMT
I believe that there were two bugs with the same error, one in gvfs-smb (which has been fixed) and one in Samba fixed by this patch.

(Oops: Accidentally attached my tarball again)
Comment by Mark Blakeney (bulletmark) - Wednesday, 27 April 2022, 21:56 GMT
Just updated my system and got new smbclient 4.16.0-5 -> 4.16.0-6 so I retested and I can now connect anonymously just fine. Note that samba version on Arch ARM server is unchanged at 4.16.0-5.1 (which, as my comment above, did not work yesterday).

Loading...