Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74247 - rename package to secrets | gnome-secrets

Attached to Project: Community Packages
Opened by Fabian Bornschein (fabis_cafe) - Saturday, 26 March 2022, 12:21 GMT
Last edited by Antonio Rojas (arojas) - Monday, 28 March 2022, 12:18 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With the name-change of upstream, that was mentioned here: https://bugs.archlinux.org/task/73129?project=5&string=gnome-passwordsafe, I would prefer to also change the name of the Arch package to 'secrets' or 'gnome-secrets'.

Why would this be a good idea?

1. Currently for a new user it's just not to find via pacman,

pacman -Ss secrets

Just doesn't print out anything related. So the only way to find secrets is to know the history of the project.

2. The binary name is "secrets", the git-repo-name is "secrets" and the App-identifier is "org.gnome.World.Secrets".


Why would it be bad?

As nothing depends on it, it would not create conflicts. We tried to rename 2 month back in the gnome unstable (fcgu) repo without any problems. Given the small user base of it, that doesn't say much, though.


Secrets or gnome-secrets?
Because the binary name is secrets I would prefer the package to be secrets as well, but that's only me. :)

----

Related AUR PKGBUILDS
* https://aur.archlinux.org/packages/secrets
* https://aur.archlinux.org/packages/secrets-git
* https://aur.archlinux.org/packages/gnome-passwordsafe-git
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 28 March 2022, 12:18 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#73129

Loading...