Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74187 - [linux] Kernel 5.16.15 and 5.16.16 break the Atheros AR93xx Adapter on iMac 2011

Attached to Project: Arch Linux
Opened by Roman Petrov (NWhisper) - Tuesday, 22 March 2022, 05:54 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 07 April 2022, 14:25 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 17
Private No

Details

Description:
Kernel 5.16.15 and 5.16.16 break the Qualcomm Atheros AR93xx Wireless Network Adapter (subsystem: Apple Inc. AirPort Extreme, driver in use: ath9k).

During the work, the connection is very often broken, and CTRL-EVENT-BEACON-LOSS messages appear in dmesg.
With kernel version 5.16.14, this problem does not exist.


Additional info:
* linux-5.16.15.arch1-1-x86_64, linux-5.16.16.arch1-1-x86_64

Steps to reproduce:
Install archlinux with kernel 5.16.15 or 5.16.16 on an Apple iMac 21.5-inch Mid 2011, connect to wi-fi and run speedtest.net.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 07 April 2022, 14:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.17.1.arch1-1
Comment by Paul Kerry (paulkerry) - Tuesday, 22 March 2022, 10:37 GMT
There's an upstream bug reported, with the commits identified that are causing the issue...
https://bugzilla.kernel.org/show_bug.cgi?id=215703

Note that the same commits have been applied to 5.15.29 and upwards, so you cannot revert to the latest LTS kernel 5.15.30-1 as that exhibits the same problem: you can use 5.16.14 or 5.15.28 until upstream fixes this: use the ALA or a local copy to revert.

Regards
Paul.
Comment by Marcell Meszaros (MarsSeed) - Tuesday, 22 March 2022, 11:31 GMT
I concur. ASUS laptop (K501LX) from 2016.
Problem occurs since linux 5.16.15 and linux-lts 5.15.29.

03:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
Subsystem: AzureWave Device 2208
Flags: bus master, fast devsel, latency 0, IRQ 19
Memory at a3100000 (64-bit, non-prefetchable) [size=512K]
Expansion ROM at a3180000 [disabled] [size=64K]
Kernel driver in use: ath9k
Kernel modules: ath9k

Had to downgrade to linux 5.16.14.
Otherwise Wi-Fi is unusable with constant disconnect-reconnect because of CTRL-EVENT-BEACON-LOSS.
Comment by Marcell Meszaros (MarsSeed) - Tuesday, 22 March 2022, 11:36 GMT
On the thread[1] mentioned by @paulkerry, they say linux 5.17 is also affected.

User gzhqyz mentions two commits which caused this.
Reverting them solves the issue for at least linux 5.16 and 5.17
according to multiple commenters:

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=aa6f8dcbab473f3a3c7454b74caa46d36cdc5d13
swiotlb: rework "fix info leak with DMA_FROM_DEVICE"

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ddbd89deb7d32b1fbb879f48d68fda1a8ac58e8e
swiotlb: fix info leak with DMA_FROM_DEVICE

[1] https://bugzilla.kernel.org/show_bug.cgi?id=215703
Comment by Marcell Meszaros (MarsSeed) - Wednesday, 23 March 2022, 03:24 GMT
Another user was successful in fixing the issue, this time on Arch, by
reverse-applying the problematic commits:

Quoted from jakalof on bugzilla.kernel[1]:
"
If this will help anyone; here is what I did on arch in PKGBUILD prepare()

patch -Rp1 -i ../aa6f8dcbab473f3a3c7454b74caa46d36cdc5d13.patch
patch -Rp1 -i ../ddbd89deb7d32b1fbb879f48d68fda1a8ac58e8e.patch
"
[1] https://bugzilla.kernel.org/show_bug.cgi?id=215703
Comment by A. Bosch (progandy) - Wednesday, 23 March 2022, 20:56 GMT
Here is a related mailing list discussion. It looks like a revert of the patches is likely.

https://lore.kernel.org/linux-wireless/1812355.tdWV9SEqCh%40natalenko.name/
Comment by Marcell Meszaros (MarsSeed) - Thursday, 24 March 2022, 15:16 GMT
Not sure how speedy will the kernel devs' resolution be.

But the thread quoted by @progandy concerns only ath9k AP mode (with the likes of hostapd), and not client mode.

For AP mode, reverting only aa6f8dcbab473f3a3c7454b74caa46d36cdc5d13 fixes the issue, according to this reply:

https://lore.kernel.org/linux-wireless/5806580.lOV4Wx5bFT%40natalenko.name/
Comment by Antonio Corbi bellot (acorbi) - Saturday, 26 March 2022, 09:58 GMT
Hi!

I'm experimenting similar problems on an Asus laptop with atheros chipset:

Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Wifi is completely borked with latest kernels as said in previous comments.
Comment by Omar ZD (Omar) - Saturday, 26 March 2022, 10:28 GMT
same issue here
network card: Qualcomm Atheros AR9485,
kernel: 5.15.30-1-lts
reverting to 5.15.28-1-lts solves the issue for now.
Comment by Kandelai (kandelai) - Monday, 28 March 2022, 15:46 GMT
It appears this issue has been fixed, and will be in the next round of kernel releases, including stable.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=bddac7c1e02ba47f0570e494c9289acea3062cc1
Comment by Marcell Meszaros (MarsSeed) - Monday, 28 March 2022, 16:45 GMT
It's not a fix per se, it's only an official revert of commit:

aa6f8dcbab473f3a3c7454b74caa46d36cdc5d13

@heftig this revert is not yet in today's 5.15.32 / 5.17.1.
Could you please revert it in the meantime in current [testing] repo kernels?

Otherwise affected people will have to wait 7-10 more days for the fix.

It's been verified that a simple reverse patch / revert commit works
and fixes this issue on lts and stable 5.15/5.16/5.17 kernels.
Comment by Kandelai (kandelai) - Monday, 28 March 2022, 16:46 GMT
It appears this issue has been fixed, and will be in the next round of kernel releases, including stable.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=bddac7c1e02ba47f0570e494c9289acea3062cc1
Comment by Marcell Meszaros (MarsSeed) - Monday, 28 March 2022, 17:13 GMT
@kandelai please take care not to double-submit your comment :)

@heftig please revert commit aa6f8dcbab473f3a3c7454b74caa46d36cdc5d13,
it's been done by Linus Torvalds on linux git master, but
not yet as of linux 5.15.32 and 5.17.1
Comment by Marcell Meszaros (MarsSeed) - Monday, 28 March 2022, 17:29 GMT
+1: there is also a new 5.16.18 out today, also without the mentioned revert.
Comment by Kandelai (kandelai) - Monday, 28 March 2022, 18:44 GMT
It appears this issue has been fixed, and will be in the next round of kernel releases, including stable.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=bddac7c1e02ba47f0570e494c9289acea3062cc1
Comment by Kandelai (kandelai) - Monday, 28 March 2022, 18:46 GMT
Sorry, not sure what is going on. I only submitted my comment once. Weird site glitch?
Comment by jeff godden (jgodden) - Monday, 28 March 2022, 20:36 GMT
There's this somewhat disappointing declaration (https://bugzilla.kernel.org/show_bug.cgi?id=215703#c13):

2022-03-27 09:41:51 UTC
> 5.17.1 still have this issue. I had to patch it to get Wifi working again.
> Maybe this last revert will be available on 5.17.2
...
> The revert is queued for 5.17.2 (among others):
> https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/tree/queue-5.17/revert-swiotlb-rework-fix-info-leak-with-dma_from_device.patch

so for those of us uncertain about how to proceed toward downgrading a kernel (given crufty graphics cards and whatnot) we have to continue to randomly type: "sudo systemctl restart wpa_supplicant@wlp4s0.service" for little while longer.

Addendum: Last night's push of 5.17.1-arch1-1 clearly fixed all the problems I was having with my Qualcomm Atheros AR93xx Wireless card. Thank you very much Mr Steffens! (i think you patched one version ahead for us)
Comment by Marcell Meszaros (MarsSeed) - Thursday, 07 April 2022, 07:43 GMT
Not fixed in [linux-lts] 5.15.32-1 (5.15.29 and up was mentioned in first comment. Do we need a new task for linux-lts for same issue?)
Comment by loqs (loqs) - Thursday, 07 April 2022, 08:11 GMT Comment by Marcell Meszaros (MarsSeed) - Thursday, 07 April 2022, 14:18 GMT
@loqs I know, I've asked for reopening this and fixing linux-lts 10 days ago..
Comment by Jan Alexander Steffens (heftig) - Thursday, 07 April 2022, 14:25 GMT
This bug is about linux, not linux-lts.

Loading...