Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7416 - dependencies are not always resolved properly

Attached to Project: Pacman
Opened by Alexander Baldeck (kth5) - Monday, 11 June 2007, 07:54 GMT
Last edited by Dan McGee (toofishes) - Friday, 28 September 2007, 18:29 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Dale Blount (dale)
Jason Chu (jason)
Aaron Griffin (phrakture)
Architecture All
Severity High
Priority Urgent
Reported Version 3.0.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
I just added a new qemu with kvm support for testing/x86_64 (11th June 2007). This one requires kvm-modules to be installed as runtime dependency. Both packages are properly in the db.tar.gz that should not be the problem. When I hit: "pacman -S qemu" with none of the two installed, it will only install qemu. /var/lib/pacman/local/qemu-*/depends even has kvm-modules as depends listed when qemu has been installed...

Steps to Reproduce:
see above
This task depends upon

Closed by  Dan McGee (toofishes)
Friday, 28 September 2007, 18:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in scripts
Comment by Alexander Baldeck (kth5) - Monday, 11 June 2007, 08:26 GMT
Found out what is wrong. The db.tar.gz does not have it in qemu-*/depends but the pkg.tar.gz has in .PKGINFO. This probably was cause by my switch on depends for x86_64 only. The vaiable $CARCH is empty when running db-* unless makepkg.conf is sourced.
Comment by Alexander Baldeck (kth5) - Monday, 11 June 2007, 08:28 GMT
... or:

export CARCH=x86_64 && db-testing64
Comment by Aaron Griffin (phrakture) - Monday, 11 June 2007, 20:13 GMT
This should probably be added to the /arch/db-* scripts, an export for the CARCH variable....

Adding dale and jason, as one of them might be faster than I
Comment by Dan McGee (toofishes) - Monday, 09 July 2007, 20:35 GMT
Dale, Jason, or anyone else that works with these?
Comment by Jason Chu (jason) - Monday, 09 July 2007, 20:54 GMT
Ok, I set the CARCH to x86_64 for those scripts.

Can someone verify that it works?
Comment by Dan McGee (toofishes) - Friday, 28 September 2007, 17:52 GMT
Status?
Comment by Aaron Griffin (phrakture) - Friday, 28 September 2007, 18:22 GMT
It seems to be working fine now... Alex, is this closable?
Comment by Alexander Baldeck (kth5) - Friday, 28 September 2007, 18:24 GMT
Yes, it is indeed. :)

Loading...