Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74109 - [electron15] Crash on start-up when using up to date wlroots

Attached to Project: Community Packages
Opened by Robin Ebert (Molytho) - Sunday, 13 March 2022, 15:59 GMT
Last edited by David Thurstenson (thurstylark) - Sunday, 13 March 2022, 21:27 GMT
Task Type Bug Report
Category Upstream Bugs
Status Assigned
Assigned To Nicola Squartini (tensor5)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
This bug makes electron crash on start-up when using wayland: https://github.com/electron/electron/issues/32487.
It is fix with an patch in the electron16 package: https://github.com/archlinux/svntogit-community/blob/packages/electron16/trunk/wayland-fix-binding-to-wrong-version.patch
I wrote a backport for 15: https://github.com/electron/electron/pull/33038

Is it possible to apply these patches until they are upstreamed? (as it is done with the electron16 package)
https://raw.githubusercontent.com/electron/electron/56fb43e07454c91a3cd60770f12db19ff3aa6b0a/patches/chromium/fixed_terminate_caused_by_binding_to_wrong_version.patch
https://raw.githubusercontent.com/electron/electron/56fb43e07454c91a3cd60770f12db19ff3aa6b0a/patches/chromium/follow_wayland_specification_regarding_xkb_keymap.patch


Additional info:
* Needs up to date wlroots compositor.

Steps to reproduce:
Try to run it on up-to-date wlroots with: --enable-features=UseOzonePlatform --ozone-platform=wayland
This task depends upon

Comment by Nicola Squartini (tensor5) - Monday, 14 March 2022, 18:35 GMT
Thank you, I applied your PR.

Loading...