Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74085 - bird: babel protocol is broken in 2.0.9

Attached to Project: Arch Linux
Opened by Jerry Xiao (JerryXiao) - Thursday, 10 March 2022, 15:03 GMT
Last edited by Sébastien Luttringer (seblu) - Wednesday, 23 March 2022, 09:46 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sébastien Luttringer (seblu)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Although bird v2.0.9 has not been packaged yet, it's worth mentioning that the babel protocol is broken in v2.0.9. An upstream fix is present at https://gitlab.nic.cz/labs/bird/-/commit/fcb4dd0c831339c4374ace17d8f2ae6ebfeed279. Due to the release cycle of bird we can expect anywhere between several months up to a year of waiting until the next release. So including the fix inside the package is highly recommended.

Additional info:
* package version(s)
bird 2.0.9-1
* config and/or log files etc.
Nothing
* link to upstream bug report, if any
https://gitlab.nic.cz/labs/bird/-/commit/fcb4dd0c831339c4374ace17d8f2ae6ebfeed279

Steps to reproduce:
Nothing
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Wednesday, 23 March 2022, 09:46 GMT
Reason for closing:  Fixed
Additional comments about closing:  bird-2.0.9-2
Comment by Toke Høiland-Jørgensen (tohojo) - Tuesday, 15 March 2022, 18:03 GMT
+1, please add that bugfix when packaging 2.0.9 :)
Comment by Toke Høiland-Jørgensen (tohojo) - Tuesday, 22 March 2022, 20:50 GMT
So bird-2.0.9-1 is now in the repos without this patch. So ping?
Comment by Sébastien Luttringer (seblu) - Wednesday, 23 March 2022, 09:44 GMT
Sorry, I don't know why it was bumped by another dev. Will push a patch asap.

Loading...