Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74063 - [podman] optional dependencies catatonit, netavark, worth considering them as required, aardvark-dns

Attached to Project: Community Packages
Opened by Lichtprotoss (Lichtprotoss) - Wednesday, 09 March 2022, 00:19 GMT
Last edited by David Runge (dvzrv) - Monday, 09 May 2022, 10:38 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Morten Linderud (Foxboron)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Hi all

I hope you are all safe. Thanks for providing podman 4 package upgrade so quickly. Since I am upgrading my environments with podman 4 now, I have some thoughts on the podman package. Some dependencies are optional, where I think it's worth considering them as required.

- catatonit
=> 'pause' image not building without (see Wiki: https://wiki.archlinux.org/title/Podman#Error_building_pause_image_after_Podman_upgrade_3.x_to_4.0)

- netavark
"Therefore, with rootfull containers, the default networking mode is to use netavark." (see Basic Networking Guide for Podman: https://github.com/containers/podman/blob/main/docs/tutorials/basic_networking.md)
As it is regarded as default, shouldn't it be rather required than optional?

- aardvark-dns
"Support for container DNS resolution via the aardvark-dns project" (see Netavark Readme https://github.com/containers/netavark/ and Podman Blog https://podman.io/blogs/2022/02/04/network-usage.html)
This package could be classified as optional

Thanks for your consideration and feedback.

Best Regards
Lichtprotoss

Additional info:
podman 4.0.1-1

Steps to reproduce:
sudo pacman -S podman

This task depends upon

Closed by  David Runge (dvzrv)
Monday, 09 May 2022, 10:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with podman 4.1.0-1
Comment by David Runge (dvzrv) - Sunday, 13 March 2022, 11:34 GMT
@Lichtprotoss: Thanks for the suggestions.

I have been following upstream's packaging suggestions [1][2][3].
Do note that pacman does not have the "suggests" concept.
To further distinguish the container-network-stack provider we could definitely think of introducing a versioned provides as well to auto-integrate netavark via containers-common.

FYI: catatonit has been an optional dependency since before podman 4.0.0. It is also only an optional requirement on e.g. Fedora.

[1] https://github.com/containers/netavark/blob/main/DISTRO_PACKAGE.md#dependency-on-aardvark-dns
[2] https://github.com/containers/netavark/blob/main/DISTRO_PACKAGE.md#relationship-with-the-cni-plugins-package
[3] https://github.com/containers/podman/blob/main/DISTRO_PACKAGE.md#distro-packagers
Comment by Lichtprotoss (Lichtprotoss) - Monday, 14 March 2022, 21:18 GMT
Thanks for providing the upstream packaging suggestions. After reading through it, with integrating netavark into containers-common it is solved, from my perspective. aardvark-dns is optional for podman and for netavark, which solves it, too.

Personally, I still have not fully understood, why catatonit is optional on Fedora [1], since it is definitely needed at least with my configuration. Most likely, I miss something. :-)

[1] https://src.fedoraproject.org/rpms/podman/blob/rawhide/f/podman.spec
Comment by Morten Linderud (Foxboron) - Monday, 14 March 2022, 21:22 GMT
I think Fedora marking catatonit as optional is a mistake on their end. I intend to make it required after looking a bit more on when it's used for normal podman usage.
Comment by David Runge (dvzrv) - Friday, 06 May 2022, 18:25 GMT
I have added catatonit to depends (podman 4.1.0-1 in [community-testing] and netavark is pulled in via container-network-stack>1 (containers-common 0.48.0-1 in [community-testing]).

Please let me know if this works for you.
Comment by Lichtprotoss (Lichtprotoss) - Sunday, 08 May 2022, 11:12 GMT
FYI: Just tested it and worked for my setup.

Loading...