Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74062 - [linux-zen] 5.16.13-zen1-1 does not include Nvidia modules

Attached to Project: Arch Linux
Opened by Arto Gahr (artogahr) - Tuesday, 08 March 2022, 22:06 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 09 March 2022, 02:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating to linux-zen 5.16.13-1 (using paru), mkinitcpio -P linux-zen gives out the below errors:
==> ERROR: module not found: `nvidia'
==> ERROR: module not found: `nvidia_modeset'
==> ERROR: module not found: `nvidia_uvm'
==> ERROR: module not found: `nvidia_drm'

The normal arch 5.16.13-1 kernel seems to include them, but not the zen kernel:

➜ 5.16.13-arch1-1 | ls extramodules
bbswitch.ko.xz nvidia-drm.ko.xz nvidia.ko.xz nvidia-modeset.ko.xz nvidia-peermem.ko.xz nvidia-uvm.ko.xz
➜ 5.16.13-arch1-1 | grep -R nvidia_drm
modules.alias:alias pci:v000010DEd*sv*sd*bc06sc80i00* nvidia_drm
modules.alias:alias pci:v000010DEd*sv*sd*bc03sc02i00* nvidia_drm
modules.alias:alias pci:v000010DEd*sv*sd*bc03sc00i00* nvidia_drm
➜ 5.16.13-arch1-1 | cd /lib/modules/5.16.13-zen1-1-zen
➜ 5.16.13-zen1-1-zen | ls extramodules
ls: cannot access 'extramodules': No such file or directory
➜ 5.16.13-zen1-1-zen | grep -R nvidia_drm
➜ 5.16.13-zen1-1-zen |
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 09 March 2022, 02:10 GMT
Reason for closing:  Not a bug
Additional comments about closing:  2022-03-09: A task closure has been requested. Reason for request: Not a bug
Comment by Doug Newgard (Scimmia) - Tuesday, 08 March 2022, 23:04 GMT
Read the Nvidia wiki page. No kernel package includes them.

Loading...