Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74049 - speedcrunch needs newer Qt libraries

Attached to Project: Community Packages
Opened by Vuk Savić (vuksavic) - Monday, 07 March 2022, 10:49 GMT
Last edited by Antonio Rojas (arojas) - Monday, 07 March 2022, 14:51 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

speedcrunch fails to start:

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
[1] 706508 IOT instruction (core dumped) speedcrunch

running from Lenovo ThinkPad T420s(i7-2640M, 8GB)
i suppose just needs to be repackaged with new libraries? :)
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 07 March 2022, 14:51 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Monday, 07 March 2022, 12:01 GMT
Please post a backtrace of the crash
Comment by Vuk Savić (vuksavic) - Monday, 07 March 2022, 14:00 GMT
(gdb) run --no-daemon --verbose speedcrunch
Starting program: /usr/bin/speedcrunch --no-daemon --verbose speedcrunch
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff3136640 (LWP 775561)]

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.425: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.425: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.425: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.426: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.426: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.426: Unable to locate theme engine in module_path: "murrine",

(speedcrunch:775557): Gtk-WARNING **: 14:58:44.426: Unable to locate theme engine in module_path: "murrine",
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)

Thread 1 "speedcrunch" received signal SIGABRT, Aborted.
0x00007ffff682f34c in __pthread_kill_implementation () from /usr/lib/libc.so.6

i've installed murrine theme after this, that didn't change anything
Comment by Antonio Rojas (arojas) - Monday, 07 March 2022, 14:32 GMT
full backtrace, please. Type "bt" after the crash.
Comment by Vuk Savić (vuksavic) - Monday, 07 March 2022, 14:41 GMT
Starting program: /usr/bin/speedcrunch --no-daemon --verbose
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7ffff3136640 (LWP 817408)]

Thread 1 "speedcrunch" received signal SIGABRT, Aborted.
0x00007ffff682f34c in __pthread_kill_implementation () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7ffff3136640 (LWP 817408) "QXcbEventQueue"):
#0 0x00007ffff68a62af in poll () at /usr/lib/libc.so.6
#1 0x00007ffff3b3663b in () at /usr/lib/libxcb.so.1
#2 0x00007ffff3b3837b in xcb_wait_for_event () at /usr/lib/libxcb.so.1
#3 0x00007ffff33e6b12 in () at /usr/lib/libQt5XcbQpa.so.5
#4 0x00007ffff6db98cc in () at /usr/lib/libQt5Core.so.5
#5 0x00007ffff682d5c2 in start_thread () at /usr/lib/libc.so.6
#6 0x00007ffff68b2584 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7ffff3af2cc0 (LWP 817403) "speedcrunch"):
#0 0x00007ffff682f34c in __pthread_kill_implementation () at /usr/lib/libc.so.6
#1 0x00007ffff67e24b8 in raise () at /usr/lib/libc.so.6
#2 0x00007ffff67cc534 in abort () at /usr/lib/libc.so.6
#3 0x00007ffff6d74ee4 in qt_assert(char const*, char const*, int) () at /usr/lib/libQt5Core.so.5
#4 0x00007ffff6d92c55 in () at /usr/lib/libQt5Core.so.5
#5 0x00007ffff17eb3d5 in () at /usr/lib/qt/plugins/styles/libqgtk2style.so
#6 0x00007ffff7a470ce in QStyleFactory::create(QString const&) () at /usr/lib/libQt5Widgets.so.5
#7 0x00007ffff7a6a171 in QProxyStyle::QProxyStyle(QString const&) () at /usr/lib/libQt5Widgets.so.5
#8 0x00007ffff18a39ac in () at /usr/lib/qt/plugins/styles/libqt5ct-style.so
#9 0x00007ffff7a470ce in QStyleFactory::create(QString const&) () at /usr/lib/libQt5Widgets.so.5
#10 0x00007ffff79d4fc2 in QApplication::style() () at /usr/lib/libQt5Widgets.so.5
#11 0x00007ffff79d5185 in QApplicationPrivate::initialize() () at /usr/lib/libQt5Widgets.so.5
#12 0x00007ffff79d5447 in QApplicationPrivate::init() () at /usr/lib/libQt5Widgets.so.5
#13 0x00005555555a291e in ()
#14 0x000000006204ad92 in ()
#15 0x00000003f67a64e8 in ()
#16 0x0000000000000000 in ()

sorry for making you handguiding me
hope this helps, i re-read Debugging/Getting traces from the wiki
Comment by Antonio Rojas (arojas) - Monday, 07 March 2022, 14:51 GMT
#5 0x00007ffff17eb3d5 in () at /usr/lib/qt/plugins/styles/libqgtk2style.so

You are using an unsupported Qt style

Loading...