Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#74016 - [nextcloud-app-calendar] Requires PHP <= 8.0

Attached to Project: Community Packages
Opened by Chih-Hsuan Yen (yan12125) - Thursday, 03 March 2022, 07:34 GMT
Last edited by Chih-Hsuan Yen (yan12125) - Saturday, 07 May 2022, 09:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
David Runge (dvzrv)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 12
Private No

Details

Description:
Upstream version 3.1.0 now restricts compatible PHP versions https://github.com/nextcloud/calendar/commit/c4a166db49c08670dcec7e8088d5baa44b85ac9d, causing the following error during `occ upgrade`:

Exception: App "Calendar" cannot be installed because the following dependencies are not fulfilled: PHP with a version lower than 8.0 is required.
Update failed

Additional info:
* community/nextcloud-app-calendar 1:3.1.0-1
* Upstream work-in-progress pull request for PHP 8.1 compatibility: https://github.com/nextcloud/calendar/pull/3996

Steps to reproduce:
Run nextcloud on PHP 8.1, upgrade nextcloud-app-calendar and run `occ upgrade`
This task depends upon

Closed by  Chih-Hsuan Yen (yan12125)
Saturday, 07 May 2022, 09:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  nextcloud-app-calendar 1:3.3.0-1
Comment by Joakim Ekblad (aio) - Wednesday, 09 March 2022, 07:28 GMT
There should be a newer version of the NextCloud available as a whole (since the release of 4.4.0 is delayed) which fix this PHP 8.1 problem. See this: https://github.com/nextcloud/notes/issues/807
Comment by David Runge (dvzrv) - Wednesday, 09 March 2022, 11:45 GMT
@aio: this ticket is about nextcloud-app-calendar not nextcloud-app-notes :)
Comment by Joakim Ekblad (aio) - Wednesday, 09 March 2022, 13:55 GMT
Haha :) Doh, sorry!
Comment by Moabit (Moabit) - Thursday, 24 March 2022, 09:09 GMT
Should this package be reverted? I have it pinned, but currently the package doesn't even work.
Comment by Mathijs van de Nes (mvdnes) - Thursday, 24 March 2022, 18:42 GMT Comment by Daniil (daniil-berg) - Wednesday, 30 March 2022, 15:39 GMT
Just checking because it says "this task depends upon FS#73452", which seems to be false, since upstream already fixed the issue:
https://github.com/nextcloud/calendar/commit/e605d3d2b55e097d71abbc71ae295a2a22199265
Does the nextcloud issue really block this from being fixed? Is there anything else that needs to happen before the upstream changes are incorporated?
Comment by Chih-Hsuan Yen (yan12125) - Wednesday, 30 March 2022, 15:45 GMT
> Does the nextcloud issue really block this from being fixed?

Not really. I added that ticket for tracking related issues - sorry for confusion.

> Is there anything else that needs to happen before the upstream changes are incorporated?

Once a new version of nextcloud-app-calendar is out, I believe people can verify if that works with PHP 8.1 and then close this ticket.
Comment by Bjoern Bidar (Thaodan) - Friday, 15 April 2022, 13:57 GMT
>Once a new version of nextcloud-app-calendar is out, I believe people can verify if that works with PHP 8.1 and then close this ticket.

Can you apply the upstream patch to fix the package?
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 16 April 2022, 05:25 GMT
> Can you apply the upstream patch to fix the package?

I guess it's possible. I'll let package maintainers decide. Anyway, I've switched to php from 8.1 to 7.4 due to this bug.
Comment by Daniil (daniil-berg) - Friday, 22 April 2022, 16:45 GMT
@yan12125
Can you please share how you did that? I installed php74 from the AUR alongside the "regular" php and even set up a symlink so that `php` resolves to the older binary. Still I get the error when trying to re-install the calendar app.

EDIT: Nevermind. Figured it out. Turns out there are two environment variables used in the `/usr/bin/occ` script that can be set to the PHP config and PHP binary. Calling

NEXTCLOUD_PHP_CONFIG=/etc/php74/php.ini NEXTCLOUD_PHP=/usr/bin/php74 occ upgrade

did the trick.
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 07 May 2022, 02:31 GMT
nextcloud-app-calendar 3.3.0-1 is out. Could someone check if that works with PHP 8.1?
Comment by Mathijs van de Nes (mvdnes) - Saturday, 07 May 2022, 06:25 GMT
The release notes state that PHP 8.1 is supported, and `occ upgrade` still works after installing 3.3.0-1. I would say this is fixed.
Comment by Chih-Hsuan Yen (yan12125) - Saturday, 07 May 2022, 09:46 GMT
Thanks for testing! If there is still an issue with nextcloud-app-calendar and PHP 8.1, feel free to open a new task or hit "Re-open this task" above.

Loading...