Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73970 - [util-linux] FTBFS, missing raw.h

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Sunday, 27 February 2022, 07:09 GMT
Last edited by Christian Hesse (eworm) - Monday, 28 February 2022, 11:07 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

"
configure: error: raw selected, but required raw.h header file not available
"

This looks like the raw driver has been finally deprecated in the kernel:

debian-bugs-dist@lists.debian.org/msg1820043.html"> https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1820043.html

usr/include/sys/raw.h is still there in glibc, so raw.c can be patched to
use sys/raw.h instead of linux/raw.h. But I think when the drop in the kernel
(https://github.com/torvalds/linux/commit/603e4922f1c81fc2ed3a87b4f91a8d3aafc7e093)
arrives in mainstream kernels, all you will get is an error message when using
'raw'.

Additional info:
* package version(s): 2.37.4-1

Steps to reproduce:
asp32 export core/util-linux
cd util-linux
staging-x86_64-build
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 28 February 2022, 11:07 GMT
Reason for closing:  Fixed
Additional comments about closing:  in SVN

Loading...