Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73930 - [nextcloud-app-notes] Exception: App "Notes" - PHP with a version lower than 8.0 is required.

Attached to Project: Community Packages
Opened by Musikolo (Musikolo) - Wednesday, 23 February 2022, 04:32 GMT
Last edited by David Runge (dvzrv) - Tuesday, 08 March 2022, 12:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
David Runge (dvzrv)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When running occ upgrade -v, I get the following error:
```
2022-02-22T21:55:00-06:00 Updating database schema
2022-02-22T21:55:00-06:00 Updated database
2022-02-22T21:55:00-06:00 Updating <notes> ...
2022-02-22T21:55:00-06:00 Exception: App "Notes" cannot be installed because the following dependencies are not fulfilled: PHP with a version lower than 8.0 is required.
2022-02-22T21:55:00-06:00 Update failed
2022-02-22T21:55:00-06:00 Maintenance mode is kept active
2022-02-22T21:55:00-06:00 Resetting log level
```

Additional info:
* package version(s)
- php: 8.1.3-1
- nextcloud: 23.0.2-1
- nextcloud-app-notes: 4.3.0-1

Steps to reproduce:
Upgrade nextcloud with `pacman -Syu` and run `occ upgrade -v`

As a temporary workaround, I had to disable this app (`occ app:disable notes`)

Is this an issue I should report upstream?
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 08 March 2022, 12:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with nextcloud-app-notes 4.3.1-1
Comment by Musikolo (Musikolo) - Wednesday, 23 February 2022, 04:38 GMT
I just found this issue (https://github.com/nextcloud/notes/issues/807) that states that this package should require PHP 8.0.

Looks like it's the same old story with nextcloud and PHP version incompatibilities! :-(
Comment by Tormod Volden (tormod) - Wednesday, 23 February 2022, 16:56 GMT
Yes, notes version 4.3.0 only supports php 7.3-8.0. Support for 8.1 was added (just bumping the compatibility declaration without further changes AFAICS) in git recently: https://github.com/nextcloud/notes/commit/38626bffe44d30bcbb6e76b99b805e31f4303f01
They are not in a rush about it because nextcloud 23 doesn't support php > 8.0 anyway: https://github.com/nextcloud/server/blob/stable23/lib/versioncheck.php
Comment by Musikolo (Musikolo) - Thursday, 24 February 2022, 02:29 GMT
Would it be possible to apply a patch to address this issue? This would solve the problem at least until there is a real fix upstream.
Comment by Musikolo (Musikolo) - Thursday, 24 February 2022, 03:23 GMT
I found I had to revert to PHP 8.0 which also solved my issue with nextcloud-app-notes.
- https://bugs.archlinux.org/task/73625#comment206319

Someone needs to pay closer attention to the Nextcloud frequent incompatibility issues with newer PHP versions and start honoring dependencies as officially supported.
Comment by David Runge (dvzrv) - Tuesday, 08 March 2022, 12:04 GMT
@sergej: Similar to how we do the version check for nextcloud server compatibility we should also ensure the php version compatibility. I guess we can extend the check() function in all apps for that.
Comment by David Runge (dvzrv) - Tuesday, 08 March 2022, 12:04 GMT
At any rate, this is fixed with 4.3.1.

Loading...