Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73918 - [bind] Has a dependency on glibc version >= 2.34

Attached to Project: Arch Linux
Opened by GΛVĪN (iamGavinJ) - Monday, 21 February 2022, 23:55 GMT
Last edited by Allan McRae (Allan) - Tuesday, 22 February 2022, 00:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
bind=9.18.0-1 has an explicit dependency on glibc>=2.34

Additional info:
* bind=9.18.0-1

Steps to reproduce:
I have glibc=2.33-5 installed. No warning or bundled upgrade was flagged when installing bind=9.18.0-1. Running `dig` produces the following error:
`
dig: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by dig)
dig: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by /usr/lib/libisc-9.18.0.so)
dig: /usr/lib/libc.so.6: version `GLIBC_2.34' not found (required by /usr/lib/libdns-9.18.0.so)
`
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 22 February 2022, 00:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  pacman -Syu
Comment by Doug Newgard (Scimmia) - Monday, 21 February 2022, 23:59 GMT
Partial updates are not supported. Update your entire system or don't update anything at all.
Comment by GΛVĪN (iamGavinJ) - Tuesday, 22 February 2022, 00:05 GMT
Is this not the correct place to report updates needed to PKGBUILD by maintainers?

I was not doing an upgrade, simply installing bind. Are you suggesting that best practice is to completely upgrade the entire system before ever installing discrete packages?
Comment by Doug Newgard (Scimmia) - Tuesday, 22 February 2022, 00:07 GMT
There are no needed updates to the PKGBUILD.

You can install packages as long as they're the same version that was available when you last updated. If you have to run pacman -Sy, you MUST update your entire system.

Loading...