Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73884 - [apitrace] GLIBC_PRIVATE is removed in glibc 2.34, causing undefined symbols

Attached to Project: Community Packages
Opened by Dang Huynh (danct12) - Saturday, 19 February 2022, 11:08 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 19 February 2022, 12:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When trying to "apitrace trace", glxtrace.so throws up an error about undefined symbol.

Additional info:
* package version(s): glibc 2.35-2, apitrace 10.0-1, mesa 21.3.6-1

* error: glxgears: symbol lookup error: /usr/bin/../lib/apitrace/wrappers/glxtrace.so: undefined symbol: __libc_dlsym, version GLIBC_PRIVATE

* This seems to caused by GLIBC_PRIVATE symbols being removed in glibc-2.34, upstream report is here: https://github.com/apitrace/apitrace/issues/756
* Upstream has made a fix: https://github.com/apitrace/apitrace/commit/d28a980802ad48568c87da02d630c8babfe163bb

Steps to reproduce:
1. Open terminal
2. Try to apitrace a 3D application "DISPLAY=:0 apitrace trace -o /tmp/test.trace glxgears"
3. The error should show up, and nothing is being traced.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 19 February 2022, 12:46 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#73813

Loading...