Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73872 - [glibc] libdl.a is empty

Attached to Project: Arch Linux
Opened by Alex Chen (fizban007) - Friday, 18 February 2022, 22:23 GMT
Last edited by Antonio Rojas (arojas) - Friday, 18 February 2022, 22:40 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After a recent update to glibc-2.35, my CUDA programs refuse to compile. The error is that they can't open the file "/usr/lib/libdl.a". Said file is owned by the glibc-2.35 package and its size is only 8 bytes, with content "!<arch>" instead of being a binary file. In an older version of glibc-2.33 this static library is present and its content is meaningful. It is not immediately obvious to me whether this change is intended by upstream, but it does break my CUDA workflow.

Additional info:
* package version(s):
glibc-2.35-2 and lib32-glibc-2.35-2

Steps to reproduce:
Inspect /usr/lib/libdl.a
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 18 February 2022, 22:40 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Friday, 18 February 2022, 22:39 GMT
See the release notes for glibc 2.34.

Loading...