Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73849 - [pass] FTBFS due to outdated tree dependency

Attached to Project: Community Packages
Opened by Jeffrey Pan (XieJiSS) - Friday, 18 February 2022, 05:41 GMT
Last edited by Toolybird (Toolybird) - Saturday, 24 December 2022, 04:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

not ok 3 - Test "show" command with unicode
#
# "$PASS" generate 🏠 &&
# "$PASS" show | grep -q 🏠
#
ok 1 - Basic move command
ok 4 - Test "show" of nonexistant password
# failed 1 among 4 test(s)

not ok 1 - Make sure find resolves correct files
#
# "$PASS" init $KEY1 &&
# "$PASS" generate Something/neat 19 &&
# "$PASS" generate Anotherthing/okay 38 &&
# "$PASS" generate Fish 12 &&
# "$PASS" generate Fishthings 122 &&
# "$PASS" generate Fishies/stuff 21 &&
# "$PASS" generate Fishies/otherstuff 1234 &&
# [[ $("$PASS" find fish | sed "s/^[ \`|-]*//g;s/$(printf \\x1b)\\[[0-9;]*[a-zA-Z]//g" | tr "\\n" -) == "Search Terms: fish-Fish-Fishies-otherstuff-stuff-Fishthings-" ]]
#
# failed 1 among 1 test(s)



This can be solved by updating the `tree` dependency to 2.0.2.



Details:
The bug is caused by `tree` 2.0.0 release, which assume json output format as default if fd 3 exist (namely, "stddata").

However, in tests/sharness.sh, `pass` use fd=3 for output redirection. `pass` didn't expect the changing of output format, which causes the tests to fail.

In 2.0.2, `tree` adds a env variable STDDATA_FD, and only outputs json when this env var is present, thus solving the bug. See tree-2.0.2/CHANGES for more details.

`tree` is marked as outdated on 2022-02-17.

Additional info:
* package version(s) 1.7.4-2
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

1. asp checkout
2. extra-x86_64-build
This task depends upon

Closed by  Toolybird (Toolybird)
Saturday, 24 December 2022, 04:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  tree 2.0.2-1

Loading...