Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73847 - glibc 2.35 broke backwards compatibility with Steam Proton

Attached to Project: Arch Linux
Opened by Patrick (imperatorpc) - Friday, 18 February 2022, 03:11 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 18 February 2022, 18:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: The removal of libcrypt.so.1 both 64bit and 32bit broke backwards compatibility with Steam Proton 4.11 (needed for some games)


Additional info:
* package version(s) glibc 2.35 and lib32-glibc 2.35
* config and/or log files etc.
* link to upstream bug report, if any

797.348:0076:0077:err:module:load_so_dll failed to load .so lib "/mnt/games3/SteamLibrary/steamapps/common/Proton 4.11/dist/bin/../lib/wine/wldap32.dll.so": libcrypt.so.1: wrong ELF class: ELFCLASS64
797.348:0076:0077:err:module:import_dll Loading library WLDAP32.dll (which is needed by L"Z:\\mnt\\games3\\SteamLibrary\\steamapps\\common\\Total War Rome II\\Rome2.dll") failed (error c000007a).

Steps to reproduce:
Set compatibility in Steam to Proton 4.11, launch game.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 18 February 2022, 18:17 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#73799 
Comment by Mark Wagie (yochananmarqos) - Friday, 18 February 2022, 04:07 GMT
Install libxcrypt-compat and/or lib32-libxcrypt-compat from the AUR. See  FS#73799 .

Loading...