Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73844 - [wpa_supplicant] Can not connect to WPA2+WPA3 networks after upgrade to 2.10

Attached to Project: Arch Linux
Opened by Christoph Seitz (go2sh) - Thursday, 17 February 2022, 20:14 GMT
Last edited by Antonio Rojas (arojas) - Friday, 18 March 2022, 12:19 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

After Upgrading to wpa_supplicant 2.10 my notebook with a Intel Corporation Centrino Advanced-N 6205 wlan adapter is not able to connect to my Fritzbox 7490 wlan with WPA2+WPA3 enabled.

The following error message comes in the dmesg:
[ 265.660395] wlan0: RX AssocResp from 34:31:c4:66:5c:c0 (capab=0x1431 status=40 aid=0)

There are also reports on the wpa_supplicant mailing list:
http://lists.infradead.org/pipermail/hostap/2022-February/040216.html

Downgrading to 2.9 fixes the issue.
This task depends upon

Comment by Christoph Seitz (go2sh) - Thursday, 17 February 2022, 20:22 GMT Comment by Danny Schneider (schnedan) - Tuesday, 29 March 2022, 22:21 GMT
same here, Fitzbox 7530, old Notebook (intel i5-520 Generation 1, Broadcom Wifi Chipset brandlabled by HP), Windows manages to connect via Wifi, Arch fails with similar kernel messages
Comment by loqs (loqs) - Wednesday, 30 March 2022, 00:16 GMT
Have you tried any of the work arounds from [1] as an alternative to downgrading wpa_supplicant?

[1] https://lists.infradead.org/pipermail/hostap/2022-March/040308.html
Comment by Dario Pilori (dapilori) - Wednesday, 30 March 2022, 07:11 GMT
Same issue with a different Wi-Fi AP, a MikroTik RB4011iGS+5HacQ2HnD-IN with RouterOS 7.1.5 and wifiwave2 package.
While I understand that, according to the workarounds suggested by loqs, this is a bug of the AP, I remark that all other operating systems are not as strict as this new release of wpa_supplicant and they work without issues.
Nevertheless, I'll try to open a bug report with MikroTik to see if this can be fixed in the AP firmware.
Comment by Danny Schneider (schnedan) - Monday, 11 April 2022, 10:31 GMT
just tested to downgrade to https://archive.archlinux.org/packages/w/wpa_supplicant/wpa_supplicant-2%3A2.9-8-x86_64.pkg.tar.zst
Did not work for me. Is there a specific 2.9.x version which should work?
Comment by nya (nya) - Sunday, 01 May 2022, 20:04 GMT
Same here. There still seems not to be a fix upstream, right?
Comment by Danny Schneider (schnedan) - Sunday, 01 May 2022, 20:58 GMT
why hurry? You just need to disable an enhanced security feature in your router and everything is fine again.
Hopefully all maintainers of all disros keep up the pressure to upstream... but for a sane expectation management, I wouldn't count on that.
Comment by Dario Pilori (dapilori) - Thursday, 30 June 2022, 18:53 GMT
I got news from Mikrotik that this issue was fixed it in the most recent release of their firmware (RouterOS v7.3.1). I tested it on my laptop, and I confirm that now it works perfectly.

Loading...