Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73830 - Some so links missing in glibc package (libdl.so and pthread.so)

Attached to Project: Arch Linux
Opened by Christoph Lehmann (chleh) - Thursday, 17 February 2022, 07:06 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 17 February 2022, 08:00 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The glibc package version 2.35-2 does not contain /usr/lib/libdl.so nor /usr/lib/libpthread.so
In glibc package version 2.33-5, which seems to have been the current version in January 2022, these files had been present, see https://archive.archlinux.org/packages/g/glibc/glibc-2.33-5-x86_64.pkg.tar.zst.
Have those two library links been forgotten or is that intended?

I didn't check, if any other library links are missing in the glibc package.

$ pacman -Ql glibc | grep -E '(libdl|pthread).*so'
glibc /usr/lib/libdl.so.2
glibc /usr/lib/libpthread.so.0
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 17 February 2022, 08:00 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Thursday, 17 February 2022, 08:00 GMT
This is intentional, those have been merged in libc.

Loading...