Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73774 - Bluez 5.63-1 doesn't work since glib2 2.70.4-1 upgrade.

Attached to Project: Arch Linux
Opened by Valentín Mauro (VMRuder) - Sunday, 13 February 2022, 15:05 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 14 February 2022, 06:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Since the last system update (1), bluetooth.service (2) fails. The system does not end up recognizing the bluetooth of the adapter (02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter). The wireless network works fine.

(1): pacman.log:
[2022-02-12T23:56:21-0300] [ALPM] upgraded glib2 (2.70.3-1 -> 2.70.4-1)
[2022-02-12T23:56:22-0300] [ALPM] upgraded glib2-docs (2.70.3-1 -> 2.70.4-1)
[2022-02-12T23:56:22-0300] [ALPM] upgraded harfbuzz (3.3.2-1 -> 3.4.0-1)
[2022-02-12T23:56:22-0300] [ALPM] upgraded harfbuzz-icu (3.3.2-1 -> 3.4.0-1)
[2022-02-12T23:56:22-0300] [ALPM] upgraded xdg-dbus-proxy (0.1.2-3 -> 0.1.3-1)
[2022-02-12T23:56:23-0300] [ALPM] upgraded gnome-user-docs (41.1-1 -> 41.2-1)
[2022-02-12T23:56:23-0300] [ALPM] upgraded lagrange (1.10.1-2 -> 1.10.5-1)
[2022-02-12T23:56:23-0300] [ALPM] upgraded lib32-glib2 (2.70.3-1 -> 2.70.4-1)
[2022-02-12T23:56:23-0300] [ALPM] upgraded lib32-harfbuzz (3.3.2-1 -> 3.4.0-1)
[2022-02-12T23:56:23-0300] [ALPM] transaction completed
[2022-02-12T23:56:24-0300] [ALPM] running '30-systemd-update.hook'...
[2022-02-12T23:56:24-0300] [ALPM] running '90-packagekit-refresh.hook'...
[2022-02-12T23:56:24-0300] [ALPM] running 'gtk-update-icon-cache.hook'...
[2022-02-12T23:56:24-0300] [ALPM] running 'update-desktop-database.hook'...

(2): journalctl -g bluetooth -r:

feb 13 11:14:47 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:13:43 spaceopera dbus-daemon[513]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:13:43 spaceopera dbus-daemon[513]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:13:43 spaceopera dbus-daemon[513]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:10:40 spaceopera dbus-daemon[513]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.ser>
feb 13 11:10:25 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:09:41 spaceopera systemd[958]: Started Bluetooth OBEX service.
feb 13 11:09:41 spaceopera systemd[958]: Starting Bluetooth OBEX service...
feb 13 11:09:41 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:09:41 spaceopera systemd[1]: Started Bluetooth management mechanism.
feb 13 11:09:41 spaceopera systemd[1]: Starting Bluetooth management mechanism...
feb 13 11:09:32 spaceopera wireplumber[670]: [string "policy-bluetooth.lua"]:121: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
[string "policy-bluetooth.lua"]:121: in upvalue 'isBluez5AudioSink'
[string "policy-bluetooth.lua"]:389: in function <[string "policy-bluetooth.lua"]:387>
feb 13 11:09:21 spaceopera NetworkManager[514]: <info> [1644761361.0420] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.34.0-1/libnm-device-plugin-bl>
feb 13 11:09:20 spaceopera dbus-daemon[513]: dbus[513]: Unknown group "bluetooth" in message bus configuration file
-- Boot 6f553983013944f9b23d85cc773a1f3a --
feb 13 11:08:38 spaceopera wireplumber[1108]: [string "policy-bluetooth.lua"]:121: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
[string "policy-bluetooth.lua"]:121: in upvalue 'isBluez5AudioSink'
[string "policy-bluetooth.lua"]:389: in function <[string "policy-bluetooth.lua"]:387>
feb 13 11:08:38 spaceopera systemd[970]: Stopped Bluetooth OBEX service.
feb 13 11:08:38 spaceopera systemd[970]: Stopping Bluetooth OBEX service...
feb 13 11:05:41 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:04:34 spaceopera dbus-daemon[505]: Unknown group "bluetooth" in message bus configuration file
feb 13 11:03:33 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:01:17 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:00:46 spaceopera systemd[970]: Started Bluetooth OBEX service.
feb 13 11:00:46 spaceopera systemd[970]: Starting Bluetooth OBEX service...
feb 13 11:00:46 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 11:00:46 spaceopera systemd[1]: Started Bluetooth management mechanism.
feb 13 11:00:46 spaceopera systemd[1]: Starting Bluetooth management mechanism...
feb 13 11:00:37 spaceopera wireplumber[662]: [string "policy-bluetooth.lua"]:121: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
[string "policy-bluetooth.lua"]:121: in upvalue 'isBluez5AudioSink'
[string "policy-bluetooth.lua"]:389: in function <[string "policy-bluetooth.lua"]:387>
feb 13 10:59:54 spaceopera NetworkManager[506]: <info> [1644760794.6213] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.34.0-1/libnm-device-plugin-bl>
feb 13 10:59:54 spaceopera dbus-daemon[505]: dbus[505]: Unknown group "bluetooth" in message bus configuration file
-- Boot ca423b037b174d488f844130bad848c2 --
feb 13 10:59:22 spaceopera systemd[951]: Stopped Bluetooth OBEX service.
feb 13 10:59:22 spaceopera unknown[1092]: [string "policy-bluetooth.lua"]:121: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
[string "policy-bluetooth.lua"]:121: in upvalue 'isBluez5AudioSink'
[string "policy-bluetooth.lua"]:389: in function <[string "policy-bluetooth.lua"]:387>
feb 13 10:59:22 spaceopera systemd[951]: Stopping Bluetooth OBEX service...
feb 13 10:58:43 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 10:58:35 spaceopera dbus-daemon[499]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.ser>
feb 13 10:58:06 spaceopera systemd[951]: Started Bluetooth OBEX service.
feb 13 10:58:06 spaceopera systemd[951]: Starting Bluetooth OBEX service...
feb 13 10:58:06 spaceopera systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth).
feb 13 10:58:06 spaceopera systemd[1]: Started Bluetooth management mechanism.
feb 13 10:58:06 spaceopera systemd[1]: Starting Bluetooth management mechanism...
feb 13 10:57:55 spaceopera wireplumber[656]: [string "policy-bluetooth.lua"]:121: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
[C]: in function 'string.find'
[string "policy-bluetooth.lua"]:121: in upvalue 'isBluez5AudioSink'
[string "policy-bluetooth.lua"]:389: in function <[string "policy-bluetooth.lua"]:387>
feb 13 10:57:42 spaceopera NetworkManager[500]: <info> [1644760662.1616] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/1.34.0-1/libnm-device-plugin-bl>
feb 13 10:57:41 spaceopera dbus-daemon[499]: dbus[499]: Unknown group "bluetooth" in message bus configuration file
-- Boot 3c753742fdaa4dd7b91f126062c9c775 --


Additional info:
* package version(s):

glib2 2.70.4-1
bluez 5.63-1
Also installed:
bluez-hid2hci 5.63-1
bluez-libs 5.63-1
bluez-plugins 5.63-1
bluez-tools 0.2.0-5
bluez-utils 5.63-1
and AUR's: pipewire-enable-bluez5 (also tested with this last package uninstalled)
Note: Also it doesn't work with bluez-git from AUR either

uname -a:
Linux spaceopera 5.16.9-zen1-1-zen #1 ZEN SMP PREEMPT Fri, 11 Feb 2022 22:42:03 +0000 x86_64 GNU/Linux
(also reproducible on: testing/linux-lts 5.15.23-1, core/linux-lts 5.15.22-1 & extra/linux-zen 5.16.8.zen1-1)
Additional info:

Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 14 February 2022, 06:44 GMT
Reason for closing:  None
Comment by Valentín Mauro (VMRuder) - Sunday, 13 February 2022, 15:41 GMT
Rebuilding bluez & Co. from ABS did not fix the problem.
Comment by Andreas Radke (AndyRTR) - Sunday, 13 February 2022, 17:12 GMT
Can you confirm downgrading glib2 fixes this?
Comment by Valentín Mauro (VMRuder) - Sunday, 13 February 2022, 19:21 GMT
Downgrading makes no difference.
I still get the message
"systemd[1]: Bluetooth service was skipped because of a failed condition check (ConditionPathIsDirectory=/sys/class/bluetooth)" in journalctl.
If the problem isn't glib2, where else do you think I should look?
Comment by Valentín Mauro (VMRuder) - Monday, 14 February 2022, 05:00 GMT
Self-healed after a complete shutdown of the laptop... Maybe it was a weird kernel module bug.

Loading...