Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7370 - libx11-1.1.2-1

Attached to Project: Arch Linux
Opened by Skottish (skottish) - Wednesday, 06 June 2007, 02:59 GMT
Last edited by Alexander Baldeck (kth5) - Wednesday, 06 June 2007, 19:22 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity Low
Priority High
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

libx11-1.1.2-1 is crashing Gimp.

Running Gimp from the command line and trying to do any drawing operation (pencil, airbrush, eraser, etc) crashes the program with this error:

[skottish@localhost pkg]$ gimp-2.3
This is a development version of GIMP. Debug messages may appear here.

jpeg-load: found image comment (38 bytes)
The program 'gimp-2.3' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
(Details: serial 29717 error_code 3 request_code 39 minor_code 0)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

(script-fu:28697): LibGimpBase-WARNING **: script-fu: wire_read(): error


I tested it with Gimp 2.3.16 and 2.3.17. azwethinkweiz posted the same problem in this thread: http://bbs.archlinux.org/viewtopic.php?id=33830

Regressing back to the previous version of libx11 solves this problem.


This task depends upon

Closed by  Alexander Baldeck (kth5)
Wednesday, 06 June 2007, 19:22 GMT
Reason for closing:  Works for me
Comment by Nate (TaintedTux) - Wednesday, 06 June 2007, 03:18 GMT
Also crashes with 2.2.15
Comment by Alexander Baldeck (kth5) - Wednesday, 06 June 2007, 14:47 GMT
confirmed for both i686 & x86_64
Comment by Alexander Baldeck (kth5) - Wednesday, 06 June 2007, 16:14 GMT
bug was critical so i forced the downgrade and uploaded 1.1.1 again. i'll leave this bug open to be closed when issues with 1.1.2 are fixed.
Comment by Nate (TaintedTux) - Wednesday, 06 June 2007, 17:59 GMT
Im not able to downgrade to 1.1.1...when I try to I get this:

warning: libx11: local (1.1.2-1) is newer than current (1.1.1-4)
:: libx11-1.1.2-1: local version is up to date. Upgrade anyway? [Y/n] y
resolving dependencies... done.
looking for inter-conflicts... done.

Targets: libx11-1.1.1-4

Total Package Size: 1.92 MB

Proceed with installation? [Y/n] y
checking package integrity...
:: Archive libx11-1.1.1-4.pkg.tar.gz is corrupted. Do you want to delete it? [Y/n] n
error: failed to commit transaction (corrupted package)
archive libx11-1.1.1-4.pkg.tar.gz is corrupted (bad MD5 or SHA1 checksum)

errors occurred, no packages were upgraded.

Loading...