Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7368 - NFS remount bug fix

Attached to Project: Arch Linux
Opened by slackhack (slackhack) - Tuesday, 05 June 2007, 16:43 GMT
Last edited by Roman Kyrylych (Romashka) - Tuesday, 25 September 2007, 09:19 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Tom Killian (tomk)
Architecture All
Severity Medium
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

clients don't remount NFS shares with usable permissions after server reboot or restart of the daemon. the problem lies the exportfs -ua command which doesn't allow reconnection, gives "stale file" error, etc.

reworked nfsd initscript by shazeal fixes the problem (nfsd.mod -- attached).

see this thread for more details:
http://bbs.archlinux.org/viewtopic.php?id=33582

   nfsd.mod (2.4 KiB)
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Tuesday, 25 September 2007, 09:19 GMT
Reason for closing:  Fixed
Comment by Daniel Rammelt (shazeal) - Thursday, 07 June 2007, 04:09 GMT
Attached is the diff of the old/new nfsd script.

Adding the exportfs -ua command alone did not fix the problem. The second issue was that the 2.6 kernels use proc to store/read the xtab information and the xtab in /var/lib/nfs was not being used on startup.

The reload part is used to clear connections while the nfsd is already running. Used more for testing while I was figuring this out but I guess it could be useful.
Comment by Tom Killian (tomk) - Thursday, 07 June 2007, 13:50 GMT
I've picked this up as I'm currently preparing the nfs-utils 1.1.0 package.
Comment by Glenn Matthys (RedShift) - Sunday, 26 August 2007, 08:14 GMT
Fix confirmed: this works for me too.
Comment by slackhack (slackhack) - Thursday, 20 September 2007, 21:41 GMT
is there an update for this? with the new nfs-utils, shares aren't remounted either on client or server reboot. thanks.
Comment by Tom Killian (tomk) - Friday, 21 September 2007, 17:49 GMT
I've just finished some init script changes to handle this with the current nfs-utils and util-linux-ng releases. Remounts after both client and server reboots are working as intended. I will upload the new package shortly.

I picked this up in June, so apologies for the delay.
Comment by slackhack (slackhack) - Monday, 24 September 2007, 17:37 GMT
fixed! thanks, works correctly again.

Loading...