Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73550 - mumble wrong build number and confusing update check

Attached to Project: Community Packages
Opened by Jan Fader (cambid) - Saturday, 29 January 2022, 20:31 GMT
Last edited by David Runge (dvzrv) - Monday, 31 January 2022, 11:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: In the actual 1.4.230-2 of mumble the internal build number of mumble is not set by calling cmake with -DBUILD_NUMBER=230.

So the built mumble thinks it's 1.4.0 and notifies the user about a new update to 1.4.230

Additional info:
* Version: 1.4.230-2
* upstream bug report: https://github.com/mumble-voip/mumble/issues/5538

Steps to reproduce:

* open mumble
* Help -> About. Check version number. (Show 1.4.0 instead of expected 1.4.230)
* Help -> Check for updates. Check for a message in the chat-window. (expected none because there is no newer version).


   mumble1.png (135.5 KiB)
This task depends upon

Closed by  David Runge (dvzrv)
Monday, 31 January 2022, 11:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with mumble 1.4.230-3
Comment by David Runge (dvzrv) - Monday, 31 January 2022, 11:46 GMT
@cambid: Thanks for the ticket.

Please do note, that the "Check for Updates" feature of mumble has no meaning when using the packaged version of mumble.

However, I will set the cmake definition BUILD_NUMBER (to set the patch level version of the application...) in an upcoming pkgrel bump, so that at least the assumption about the version check is correct.
Comment by Jan Fader (cambid) - Monday, 31 January 2022, 11:51 GMT
@dvzrv: Thanks for the update and the fix in the upcoming pkgrel bump. I've already done that on local rebuild and this works as expected.

The change is a cosmetic one. I know that the "Check for Updates" isn't useable if I use a packaged version, but other users won't know and maybe gets confused from it.

Loading...