Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73544 - [electron13] interface 'wl_output' has no event 4 (wayland only)

Attached to Project: Community Packages
Opened by Gabriel (gAb1) - Friday, 28 January 2022, 20:50 GMT
Last edited by Evangelos Foutras (foutrelis) - Monday, 07 February 2022, 19:28 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Nicola Squartini (tensor5)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 5
Private No

Details

Description:
In a pure wayland environment (without xwayland, like sway in my case), apps based on electron13 terminate (or crash) right after running them with the following error messages:
[13404:0127/154855.156820:WARNING:wayland_drm.cc(68)] Failed to get drm magic
interface 'wl_output' has no event 4
tcmalloc: large alloc 1073741824 bytes == 0x1a8140635000 @ 0x55ac37cb0aaa 0x7f3dd6507047
Failed to generate minidump.


Additional info:

* package version(s): electron13 13.6.8-2

* console output with WAYLAND_DEBUG=1 and --verbose: https://gist.github.com/ChazyTheBest/f1c59a1b387524ea077c4ecce8aa3a37

* link to upstream bug report, if any
bug report: https://github.com/electron/electron/issues/32487

solution: https://github.com/electron/electron/pull/32652

Steps to reproduce:

run an electron13 based app like code in wayland: $ code --enable-features=UseOzonePlatform --ozone-platform=wayland

- Expected behavior: the code editor opens.
- Actual result: nothing happens, the program terminates with the mentioned errors.
This task depends upon

Comment by Claudia Pellegrino (Auerhuhn) - Wednesday, 02 February 2022, 18:42 GMT
Upstream released Electron v13.6.9 today: https://github.com/electron/electron/releases/tag/v13.6.9

The release includes a fix for this issue.
Comment by Landon Getz (landongetz) - Monday, 07 February 2022, 17:30 GMT
Can confirm that installing Electron 13.6.9 from the github (I modified the PKGBUILD for the aur package electron13-bin to the new version) fixed this issue for me. I've flagged the electron13 package in community-staging as out-of-date.
Comment by Shahar Dahan (shahar) - Friday, 11 February 2022, 00:02 GMT
Hi, I'm new and just made this account to post here.

I'm curious what is required to fix this? Could I take it on? I just want to add electron 13.16.9 to the community packages.
Comment by Thomas Foernzler (thomasfoernzler) - Thursday, 17 February 2022, 21:26 GMT
The AUR-Package "electron13-bin-13.6.9-1" just gave me new erreors

45826:0217/222224.169287:WARNING:wayland_drm.cc(68)] Failed to get drm magic
[45860:0217/222224.296719:ERROR:gpu_init.cc(440)] Passthrough is not supported, GL is egl
[45860:0217/222224.299361:ERROR:viz_main_impl.cc(160)] Exiting GPU process due to errors during initialization
[main 2022-02-17T21:22:24.328Z] [File Watcher (node.js)] Request to start watching: /home/thomasf/.config/Code - OSS/User (excludes: <none>),/home/thomasf/.config/Code - OSS/User/settings.json (excludes: <none>)
[main 2022-02-17T21:22:24.342Z] Sending env to running instance...
[main 2022-02-17T21:22:24.344Z] [File Watcher (node.js)] Started watching: '/home/thomasf/.config/Code - OSS/User'
[main 2022-02-17T21:22:24.344Z] [File Watcher (node.js)] Started watching: '/home/thomasf/.config/Code - OSS/User/settings.json'
[main 2022-02-17T21:22:24.351Z] Sent env to running instance. Terminating...
[main 2022-02-17T21:22:24.351Z] Lifecycle#kill()
[main 2022-02-17T21:22:24.351Z] Lifecycle#onWillShutdown.fire()
Comment by Nicola Squartini (tensor5) - Sunday, 20 February 2022, 12:53 GMT
Electron 13.6.9 is now available in [community]. Please let me know if this issue persists.
Comment by Chjuwa Gersch (l-_-l) - Monday, 21 February 2022, 05:06 GMT
Signal is still bork, but it may be due to something else now...

```
>>sway --version
sway version 1.7

>electron13 --version
v13.6.9
>signal-desktop --use-tray-icon --enable-features=UseOzonePlatform --ozone-platform=wayland
Set Windows Application User Model ID (AUMID) { appUserModelId: 'org.whispersystems.signal-desktop' }
NODE_ENV production
NODE_CONFIG_DIR /usr/lib/signal-desktop/resources/app.asar/config
NODE_CONFIG {}
ALLOW_CONFIG_MUTATIONS undefined
HOSTNAME undefined
NODE_APP_INSTANCE undefined
SUPPRESS_NO_CONFIG_WARNING undefined
SIGNAL_ENABLE_HTTP undefined
userData: /home/user/.config/Signal
config/get: Successfully read user config file
config/get: Successfully read ephemeral config file
making app single instance
interface 'wl_output' has no event 4
^C⏎
```
Comment by q rty (q234rty) - Tuesday, 22 February 2022, 08:53 GMT
I can confirm that electron 13.6.9 fixed the issue for sway yet caused SIGTRAP on GNOME where 13.6.8 worked fine.
My guess is the upstream commit https://github.com/electron/electron/commit/ac71f57556081d90af502e55f69126c179869368 simply changed kUnsafe to kReadOnly, instead of backporting the patch from https://chromium-review.googlesource.com/c/chromium/src/+/3241224.
Comment by Chjuwa Gersch (l-_-l) - Tuesday, 22 February 2022, 09:03 GMT
What version of sway are you using?
Comment by q rty (q234rty) - Tuesday, 22 February 2022, 09:09 GMT
> What version of sway are you using?
sway 1:1.7-2 with wlroots 0.15.1-2
Also, afaik signal-desktop uses bundled electron instead of system electron so updating the system electron does nothing.
Comment by q rty (q234rty) - Tuesday, 22 February 2022, 14:34 GMT
Also, there's a line
[104830:0222/222447.517772:ERROR:platform_shared_memory_region_posix.cc(47)] Descriptor access mode (2) differs from expected (0)
when I run electron13 13.6.9 under GNOME with electron13 --enable-logging --enable-features=UseOzonePlatform --ozone-platform=wayland, which is the exact same error as in https://bugs.chromium.org/p/chromium/issues/detail?id=1246834#c11 . So yeah, this should be resolved by backporting https://chromium.googlesource.com/chromium/src/+/36f7feb5d21ad51470774395dd0bdd91778e68e1 .
Comment by Nicola Squartini (tensor5) - Sunday, 20 March 2022, 18:47 GMT
Just made a release that incorporates https://chromium.googlesource.com/chromium/src/+/36f7feb5d21ad51470774395dd0bdd91778e68e1. Thanks @q234rty for your suggestion.
Comment by q rty (q234rty) - Tuesday, 22 March 2022, 17:45 GMT
Can confirm that electron13 13.6.9-2 runs on both sway and GNOME with `electron13 --enable-features=UseOzonePlatform --ozone-platform=wayland` .

Loading...