Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73520 - gwenview depends on libkdcraw, does not install it

Attached to Project: Arch Linux
Opened by ╬╝ltraviolet nanokitty (ultraviolet) - Thursday, 27 January 2022, 00:13 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 27 January 2022, 08:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

description:

when installing gwenview via kde-applications-meta, libkdcraw is not pulled in, therefore gwenview fails to launch.

steps to reproduce:

pacman -S kde-applications-meta
gwenview

error produced:

gwenview: error while loading shared libraries: libKF5KDcraw.so.5: cannot open shared object file: No such file or directory

steps to resolve:

pacman -S libkdcraw


the odd thing is, in gwenview's PKGBUILD libkdcraw is listed as a dependency. however i can confirm that not only was it not installed, but after installing it manually i can `pacman -R libkdcraw` without triggering pacman to remove gwenview. i have gwenview 21.12.1-1 installed, and that is the current version. i'm not sure why the package does not reflect the dependencies listed in its PKGBUILD.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 27 January 2022, 08:34 GMT
Reason for closing:  Not a bug
Comment by ╬╝ltraviolet nanokitty (ultraviolet) - Thursday, 27 January 2022, 00:21 GMT
i think this may be some sort of bug in pacman, because i just went and checked the .PKGINFO in the latest gwenview package, and libkdcraw is listed as a dependency there as well. yet i can `pacman -R libkdcraw` without any complaint regarding gwenview, and `pacman -S gwenview` doesn't try to pull in libkdcraw. something is very odd here.
Comment by Antonio Rojas (arojas) - Thursday, 27 January 2022, 07:38 GMT
output of 'pacman -Qii gwenview'?
Comment by ╬╝ltraviolet nanokitty (ultraviolet) - Thursday, 27 January 2022, 08:32 GMT
well, you got me on the right track! turns out the problem is that i had previously installed trinity (a not-so-maintained kde3 fork, somewhat like mate is for gnome2 except much less complete) and it provides its own much older version of libkdcraw, installed in a non-conflicting location under /opt. hence pacman thought gwenview's dependency was satisfied when it was in fact not at all. this situation is quite an edge case, but i suppose it could be prevented by specifying a minimum version of libkdcraw that must be installed to satisfy gwenview. attached is a log of the commands i ran to discover the situation, thank you for getting me looking in the right place!

Loading...