Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#73430 - pass-otp: Package version does not match source code version

Attached to Project: Community Packages
Opened by Leonard König (LeonardK) - Thursday, 20 January 2022, 11:40 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 16 February 2022, 17:04 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Description: The package version is 1.2.0, however, if we extract the archive, we see it's still 1.1.0.

Additional info:
* package version(s): 1.2.0

Steps to reproduce:

$ wget -O - 2>/dev/null | \
zstdcat | \
tar -Ox usr/lib/password-store/extensions/otp.bash | \

This task depends upon

Comment by Leonard König (LeonardK) - Thursday, 20 January 2022, 11:43 GMT
Note that the update to 1.2.0 also added the Perl module Pass::OTP aka 'otptool' as an optional dependency which would take precedence over the default otpauth. This is required for Steam OTP codes:
Comment by Doug Newgard (Scimmia) - Thursday, 20 January 2022, 11:50 GMT
Check the upstream repo, not only was this how they shipped 1.2.0, but it's currently showing 1.1.2 in the default branch.
Comment by Levente Polyak (anthraxx) - Thursday, 20 January 2022, 11:55 GMT
That is correct from the packaging perspective and is version 1.2.0. The label has not been increased upstream before v1.2.0:
Comment by Leonard König (LeonardK) - Thursday, 20 January 2022, 13:30 GMT
Oh this is confusing. So

| git tag | VERSION | remark |
| 1.1.0 | 1.1.0 | |
| 1.2.0 | 1.1.1 | |
| -- | 1.1.2 | Add support for using Pass::OTP |

This is quite unfortunate, but I guess should be fixed upstream "first"? Probably the least invasive change would be to jump to 1.3/1.3.0 in both git tag was well as VERSION.