Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7338 - Installation fails due to file conflicts, conflicts= ignored.

Attached to Project: Pacman
Opened by dtw (dibblethewrecker) - Saturday, 02 June 2007, 07:46 GMT
Last edited by Dan McGee (toofishes) - Monday, 18 June 2007, 00:22 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture i686
Severity High
Priority Normal
Reported Version 3.0.4
Due in Version 3.0.5
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just tried to install thunar-svn and it failed due to file conflicts.

Problem is thought that each -svn package dragged in is specifically set with a conflicts field for the existing package which seems to be ignored.
This task depends upon

This task blocks these from closing
 FS#7415 - Pacman doesn't check for deps when installing a group 
Closed by  Dan McGee (toofishes)
Monday, 18 June 2007, 00:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.0.5, rebuild your DB's to ensure things are done right.
Comment by Xavier (shining) - Wednesday, 13 June 2007, 09:59 GMT
Just to clear things, it isn't pacman which is ignoring conflicts during installation, the conflicts field aren't in the community database :

pacman -Si libxfce4util-svn libxfcegui4-svn libxfce4mcs-svn exo-svn thunar-svn | grep -E "Name|Version|Conf"
Name : libxfce4util-svn
Version : 25448-2
Conflicts With : None
Name : libxfcegui4-svn
Version : 25769-1
Conflicts With : None
Name : libxfce4mcs-svn
Version : 25684-1
Conflicts With : None
Name : exo-svn
Version : 25448-1
Conflicts With : None
Name : thunar-svn
Version : 25448-1
Conflicts With : None

I don't have the slightest idea how this happened though, because apparently the PKGBUILDs do have a conflict statement, as well as the packages themselves, like :
pacman -Qi --file /var/cache/pacman/pkg/libxfce4util-svn-25448-2.pkg.tar.gz |grep -E "Name|Version|Conflicts"
Name : libxfce4util-svn
Version : 25448-2
Conflicts With : libxfce4util

Btw, the exo-svn PKGBUILD has pkgver and pkgrel on the same line, this looks odd.
Oh, this was already reported by Romashka there :
http://aur.archlinux.org/packages.php?do_Details=1&ID=7249&O=0&L=0&C=0&K=exo-svn&SB=n&SO=a&PP=25&do_MyPackages=0&do_Orphans=0&SeB=nd
Comment by Xavier (shining) - Thursday, 14 June 2007, 09:43 GMT
Note : this isn't specific to xfce packages.
ALL packages in the community database have an empty %CONFLICTS% field (in the depends file).
Comment by Xavier (shining) - Sunday, 17 June 2007, 17:02 GMT
Ah, I found the problem, it's a bug in repo-add, caused by the last change here :
http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/scripts/repo-add.diff?r1=1.9&r2=1.10&cvsroot=Pacman

The funniest thing is that I read this commit back then, but I didn't understand it (the fact that it was wrong didn't help I guess) :
http://www.archlinux.org/pipermail/pacman-dev/2007-May/008222.html

Attaching a patch against pacman cvs, and one against pacman-git.
Comment by Alex Heck (nesl247) - Sunday, 17 June 2007, 17:33 GMT
That patch definitely made the conflicts appear.
Comment by Dan McGee (toofishes) - Sunday, 17 June 2007, 17:34 GMT
I think I'll try to take care of this later today, and maybe release 3.0.5 tonight.

Loading...