Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73379 - key "C132293954BBE4AD" could not be looked up remotely

Attached to Project: Arch Linux
Opened by Richard PALO (risto3) - Sunday, 16 January 2022, 17:13 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 16 January 2022, 21:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Currently at Linux 5.10.90-1-lts #1 SMP Wed, 05 Jan 2022 13:07:40 +0000 x86_64 GNU/Linux

But cannot upgrade

$ LANG=C sudo pacman -Syu
:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
archzfs is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (45) archlinux-keyring-20220114-1 bind-9.16.24-1 btrfs-progs-5.16-1 cryptsetup-2.4.3-1 cups-filters-1.28.11-1 ding-libs-0.6.1-4 firefox-96.0.1-1 firefox-i18n-fr-96.0.1-1
gnome-desktop-1:41.3-1 gobject-introspection-1.70.0-5 gobject-introspection-runtime-1.70.0-5 gupnp-1:1.4.3-1 gvim-8.2.4106-1 iana-etc-20220110-1 iproute2-5.16.0-1
jack2-1.9.20-3 js78-78.15.0-2 libsigsegv-2.14-1 liburcu-0.13.1-1 linux-lts-5.15.14-1 linux-lts-headers-5.15.14-1 logrotate-3.19.0-1 mailutils-3.14-1 mesa-21.3.4-1
meson-0.61.0-4 ndctl-72.1-1 netctl-1.27-1 npm-8.3.1-1 pacman-mirrorlist-20220116-1 pahole-1.23-1 perl-file-which-1.27-1 postfix-3.6.4-1 postfix-pcre-3.6.4-1
postfix-pgsql-3.6.4-1 pyside2-5.15.2.1-1 python-shiboken2-5.15.2.1-1 qt5-base-5.15.2+kde+r291-1 qt5-wayland-5.15.2+kde+r41-1 strace-5.16-1 systemd-250.2-2 systemd-libs-250.2-2
systemd-sysvcompat-250.2-2 thunderbird-91.5.0-1 thunderbird-i18n-fr-91.5.0-1 vim-runtime-8.2.4106-1

Total Installed Size: 1121.56 MiB
Net Upgrade Size: 61.36 MiB

:: Proceed with installation? [Y/n]
(45/45) checking keys in keyring [#######################################################################] 100%
downloading required keys...
:: Import PGP key C132293954BBE4AD, "Sergej Pupykin <spupykin@archlinux.org>"? [Y/n]
error: key "C132293954BBE4AD" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 16 January 2022, 21:40 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 16 January 2022, 17:24 GMT
Update archlinux-keyring first.
Comment by Richard PALO (risto3) - Sunday, 16 January 2022, 21:07 GMT
That I did prior to filing the issue...
get bunches of the following:
$ LANG=C sudo pacman-key --refresh-keys
gpg: key BA1DFB64FFF979E7: "Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
pub rsa4096 2011-11-29 [SC]
AB19265E5D7D20687D303246BA1DFB64FFF979E7
uid [ full ] Allan McRae (Arch Linux Master Key) <allan@master-key.archlinux.org>

gpg: error retrieving 'dan@master-key.archlinux.org' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkp://pool.sks-keyservers.net
gpg: keyserver refresh failed: No name
==> ERROR: Could not update key: A04F9397CDFD6BB0

Comment by Doug Newgard (Scimmia) - Sunday, 16 January 2022, 21:11 GMT
That's not updating the archlinux-keyring package
Comment by Richard PALO (risto3) - Sunday, 16 January 2022, 21:22 GMT
pacman updating?
okay, that should've probably been in an install message somewhere.
Thanks

Loading...