Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73346 - [gobject-introspection] FTBFS

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 13 January 2022, 10:02 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 13 January 2022, 16:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Fails to build due to a version mismatch with glib2 (which has been updated
to 2.70.2):

==> Missing dependencies:
error: target not found: glib2=2.70.1

When I change to glib2 2.70.2 with:

_glibver=2.70.2
source[1]="git+https://gitlab.gnome.org/GNOME/glib.git?signed#tag=2.70.2"
makedepends=(${makedepends[@]//glib2=2.70.1/})
makedepends+=('glib2=2.70.2')

Then I get:

gobject-introspection/giscanner/meson.build:58:0: ERROR: File doctemplates does not exist.

Setting -D gtk_doc=false didn't help, commenting out the section:

#install_subdir('doctemplates', install_dir: giscannerdir)
..
# '@INPUT@', '@OUTPUT@'])

gobject-introspection/tests/scanner/meson.build:529:4: ERROR: Unknown variable "doc_templates".

#depends: [doc_templates],

This seems to work, but feels extremly hacky.

I finally gave up on python and regression tests:

FAILED: tests/scanner/Regress-1.0-Gjs
FAILED: tests/scanner/Regress-1.0-Python

This package blocks updates for hwids (required by libosinfo/tracker/tracker3) downstream. :-)
This problem arises because we have to rebuild more packages than expected..

Additional info:
* package version(s): 1.70.0-4
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 13 January 2022, 16:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.70.0-5

Loading...