Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73324 - [python-requests-kerberos] missing dependency on python-pyspnego

Attached to Project: Community Packages
Opened by Richard Sch├╝tz (rschuetz) - Monday, 10 January 2022, 18:56 GMT
Last edited by George Rawlinson (rawlinsong) - Monday, 17 January 2022, 20:15 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
python-requests-kerberos depends on python-pyspnego, but it is included in checkdepends only.

Additional info:
* package version 0.14.0-1

Steps to reproduce:
>>> import requests
>>> from requests_kerberos import HTTPKerberosAuth
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/usr/lib/python3.10/site-packages/requests_kerberos/__init__.py", line 17, in <module>
from .kerberos_ import HTTPKerberosAuth, REQUIRED, OPTIONAL, DISABLED
File "/usr/lib/python3.10/site-packages/requests_kerberos/kerberos_.py", line 6, in <module>
import spnego
ModuleNotFoundError: No module named 'spnego'
This task depends upon

Loading...