Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73279 - Gimp segfaults on startup

Attached to Project: Arch Linux
Opened by Sascha (Moxon) - Thursday, 06 January 2022, 18:57 GMT
Last edited by Antonio Rojas (arojas) - Monday, 10 January 2022, 07:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Trying to start gimp, but it crashes immediately with:

GLib (gthread-posix.c): Unexpected error from C library during 'pthread_setspecific': Invalid argument. Aborting.
Segmentation fault (core dumped)

Updating the system did not help, the crash happens since a couple of days. In the upstream bug report (other user, same crash), the crash just went away after an update. But unforunately not on my system.


Additional info:

* gimp package: 2.10.30-1
* bug entry upstream: https://gitlab.gnome.org/GNOME/gimp/-/issues/7681
* coredumpctl log see attachment

Steps to reproduce:

Start gimp.
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 10 January 2022, 07:22 GMT
Reason for closing:  Not a bug
Comment by Sascha (Moxon) - Monday, 10 January 2022, 06:17 GMT
Hm ... turns out gtk-update-icon-cache was not properly installed (inconsistent root file system). After reinstalling it, the crash no longer happens.

Loading...