Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73274 - [xorg-server-xephyr] does not recognize input devices, window not drawing

Attached to Project: Arch Linux
Opened by codic (codic) - Thursday, 06 January 2022, 07:20 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 20 February 2022, 19:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
After updating my system to the latest version of package xorg-server-xephyr, the package has been rendered practically useless for me. When I now run Xephyr with my usual `Xephyr -br -ac -noreset -screen 800x600 :2` the window launches but I get a long list of "unrecognized device" and I can't use keyboard or mouse inside the window. In addition to that the window seems to not draw anything as when I move another window under it, Xephyr remains transparent.

Not sure if this is an upstream bug or an arch packaging bug. Maybe we should downgrade until fixed upstream.

Attached text file `log` is simply the stdout/stderr of the program as run through bash.

Steps to reproduce:
(1) Launch Xephyr (example command from arch wiki: `Xephyr -br -ac -noreset -screen 800x600 :1`)
(2) Observe nothing working
   log (4.2 KiB)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 20 February 2022, 19:37 GMT
Reason for closing:  Fixed
Comment by codic (codic) - Thursday, 06 January 2022, 07:21 GMT
note: my system is fully updated and is stock arch.
Comment by Jonathon (jonathon) - Thursday, 06 January 2022, 20:49 GMT
Unfortunately, I cannot replicate an issue here with 21.1.3-1. Running with

```
Xephyr -br -ac -noreset -screen 800x600 :2
DISPLAY=:2 xterm
```

the expected terminal displays in the nested session, and typing etc. works.
Comment by codic (codic) - Thursday, 06 January 2022, 22:48 GMT
Interesting, perhaps it is related to hardware.
Comment by codic (codic) - Thursday, 06 January 2022, 22:48 GMT
I indeed also have 21.1.3-1; attached is some hardware information from inxi -b.
   log (1.2 KiB)
Comment by objectliteral (objectliteral) - Friday, 07 January 2022, 17:45 GMT
I think I have the same issue.

```
Xephyr -br -ac -noreset -screen 800x600 :2
DISPLAY=:2 xterm
```

does spawn an xterm window inside the Xephyr but I can't interact with it. Xephyr does complain about input devices (see attachment).

I don't know whether this breakage is recent as I installed Xephyr on this particular Arch system only today.

Comment by MonkeeSage (MonkeeSage) - Saturday, 08 January 2022, 02:42 GMT
I can reproduce on xorg-server-xephyr-21.1.3-1. I haven't used Xephyr in over a year but mouse and keyboard was definitely working previously on this same install and hardware.

Possibly related upstream bug reports although they seem to refer to a rather old commit:

https://gitlab.freedesktop.org/xorg/xserver/-/issues/733
https://gitlab.freedesktop.org/xorg/xserver/-/issues/1174
Comment by dhamp (dhampire) - Monday, 10 January 2022, 01:33 GMT
downgrade 21.1.3-1 => 21.1.2-2 solve problem(???), after downgrade packet input work.
some log attached (downgrade packet, check xephyr ( it's normal worked), upgrade packet back, check xephyr (input brocken))
21.1.2-2 - input work
21.1.3-1 - input doesn't work

xf86-input-libinput, libinput, libevdev - installed
xf86-input-evdev - doesn't installed

strange things....
Comment by Sergey Vlasov (sigprof) - Tuesday, 11 January 2022, 07:21 GMT
Looks like the problem is caused by this change in xorg-server:

https://gitlab.freedesktop.org/xorg/xserver/-/commit/b27eaa72837eebe80adfe6c257a71a6b9eaf66ee

Executing `unset XDG_SEAT` before starting Xephyr makes it work as it was before the change.
Comment by Sergey Vlasov (sigprof) - Tuesday, 11 January 2022, 07:40 GMT Comment by Claudius (clst) - Wednesday, 16 February 2022, 01:54 GMT
Upstream seems to have fixed the issue: https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/839

Somehow it's still not working for me. Xnest works fine though.
Comment by Andreas Radke (AndyRTR) - Saturday, 19 February 2022, 09:59 GMT
Please try 21.1.3-4 that also has now debug symbols available for testing.
Comment by Claudius (clst) - Sunday, 20 February 2022, 17:33 GMT
I just installed `upgraded xorg-server-xephyr (21.1.3-2 -> 21.1.3-6)`

Everything works great now. Thanks.

Loading...