Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73250 - Flickering in all GL (or Vulkan?) windows

Attached to Project: Arch Linux
Opened by skrat (skrat) - Tuesday, 04 January 2022, 01:29 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 07 February 2022, 07:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

https://youtu.be/KlvU_o9GVXE

Please see the recording first.

This is happening since recent updates in all apps that use OpenGL or Vulkan. Sorry I'm not expert, just a user reporting the issue. I'm more than happy to provide any details. My main issue is that this is happening in Blender which I use a lot, and also in WebGL in Chromium (using Ozone platform).

My setup is: sway (wayland) and pretty standard install with very little customization.
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 07 February 2022, 07:39 GMT
Reason for closing:  Upstream
Additional comments about closing:  2022-01-08: A task closure has been requested. Reason for request: The problem has been fixed(as mentioned by the person who had opened the issue, also the issue is related to a upstream bug instead of a archlinux one)
Comment by skrat (skrat) - Tuesday, 04 January 2022, 01:36 GMT
Forgot to mention: this is Intel Xe graphics

Also some interesting bits from sway output:

00:00:00.878 [ERROR] [wlr] [EGL] command: eglQueryDevicesEXT, error: EGL_BAD_ALLOC (0x3003), message: "EGL_BAD_ALLOC error
: In eglQueryDevicesEXT: Failed to allocate device list.

00:04:58.974 [ERROR] [wlr] [backend/drm/atomic.c:35] connector eDP-1: Atomic commit failed (pageflip): Device or resource
busy
Comment by skrat (skrat) - Tuesday, 04 January 2022, 01:41 GMT
Also, pacman.log
Comment by skrat (skrat) - Tuesday, 04 January 2022, 01:57 GMT
I built and run Vulkan demos, I run glxgears from mesa-utils and haven't experienced any flickers with these apps.
Comment by daimonion (demon) - Thursday, 06 January 2022, 13:15 GMT
I am also experiencing screen flicker but only inside webview window (for example, Falkon browser). Some pages don't trigger flickering, but some (Matrix chat) cause extreme flickering, so much that the page is not usable. I am not sure if this related to OP's issue, to be honest, but my flickering looks exactly the same as in the video provided. I believe the problem started in November, after icu, web-engine, webkit and falkon got upgraded (see attached file).
Comment by daimonion (demon) - Thursday, 06 January 2022, 13:30 GMT
Update: I downgraded mesa package to 21.2.5 and my problems were solved: https://bbs.archlinux.org/viewtopic.php?pid=2010965#p2010965

Perhaps this could be a workaround for this issue as well.
Comment by daimonion (demon) - Thursday, 06 January 2022, 16:37 GMT Comment by skrat (skrat) - Friday, 07 January 2022, 00:54 GMT
@daimonion yepp, I patched mesa with it and it's fixed, not even a reboot needed. thanks for that
Comment by daimonion (demon) - Saturday, 08 January 2022, 19:37 GMT
Here's the patch attached. Perhaps it could be applied to this package as a workaround until next mesa release fixes this?

Loading...