Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73239 - [xorg-server] Issue with latest NVIDIA drivers 495.46 and Mate compositor (libxpresent related?)

Attached to Project: Arch Linux
Opened by Nicolas Vila (nicolasv) - Monday, 03 January 2022, 10:13 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Tuesday, 04 January 2022, 11:07 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Xserver crashes (NVIDIA 495.46) when compositor uses present extension. It happens on 21.1.2, not tested with previous versions.
Found a working patch which solves the issue (please see details on the link below)
Enclosed is the patch tested with updated PKGBUILD

Additional info:
* This concerns at least xorg-server-21.1.2
* link to upstream bug report: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1275

Steps to reproduce:

Update NVidia drivers to 495.46 and launch Mate Desktop
Workaround : disable compositor in Mate
gsettings set org.mate.Marco.general compositing-manager false
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Tuesday, 04 January 2022, 11:07 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Duplicate of https://bugs.archlinux.org/task/73031
Comment by Nicolas Vila (nicolasv) - Monday, 03 January 2022, 18:21 GMT
Here is the full list of files needed if you want to build the patched version of xorg-server
Unzip and run "makepkg -si"
Cheers ;-)
Comment by Jonathon (jonathon) - Monday, 03 January 2022, 19:16 GMT Comment by Nicolas Vila (nicolasv) - Tuesday, 04 January 2022, 09:55 GMT
Yes indeed, you're right. Sorry for double-posting, I only noticed the bug on freedesktop
This bug was pretty annoying and I was tired to wait (since december 13th)
At least, there's a description of the fix here ;-)

Loading...