Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73234 - [telegram-desktop] v3.4.2-2 Qt6 build does not apply the system tray icon theme

Attached to Project: Community Packages
Opened by Agustín Cisneros (aerz) - Sunday, 02 January 2022, 17:37 GMT
Last edited by Antonio Rojas (arojas) - Monday, 03 January 2022, 07:50 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Since the new release built using Qt6 Telegram Desktop ignore any icon settings theme specified in xfconf:
* channel: xsettings
* property: /Net/IconThemeName

Also, opening Teelgram Desktop from the terminal throws several erros about svg:

```
qt.svg: Error while inflating gzip file: SVG format check failed
qt.svg: Error while inflating gzip file: SVG format check failed
...
```

I tested the official Telegram Desktop build and doesn't have the bug, and it doesn't throw the error messages either, so maybe the build needs to be done with other flags.


Additional info:
* Related issue: https://bugs.archlinux.org/task/72946
* Commit since problem appears: https://github.com/archlinux/svntogit-community/commit/b0d894a8d6f4027aa8d4b09cda8c082a024244e3
* Telegram official binary build that works: https://github.com/telegramdesktop/tdesktop/releases/tag/v3.4.2
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 03 January 2022, 07:50 GMT
Reason for closing:  Not a bug
Comment by Agustín Cisneros (aerz) - Monday, 03 January 2022, 02:09 GMT
Checking the problem further, I found that my previous comment is a mistake and there's no bug.

In the past builds, the icon theme was applied because I set the env variable 'QT_QPA_PLATFORMTHEME' to 'gnome' but recently, the wiki was updated (Dec 30th) with extra information for qt6. So now, by installing the qt6ct package and setting the env var to 'qt6ct', I'm able to edit the style of qt6 apps.

I will close the issue and I will try to provide more information into the wiki if it was necessary at some point.

---

Wiki article: https://wiki.archlinux.org/title/Uniform_look_for_Qt_and_GTK_applications#QGnomePlatform

Loading...