Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73214 - Latest ArchLinux 2022.01.01 ISO will not boot automatically in EFI (on Virtualbox)

Attached to Project: Arch Linux
Opened by Jilles Groenendijk (jilles_com) - Saturday, 01 January 2022, 13:45 GMT
Last edited by David Runge (dvzrv) - Tuesday, 01 February 2022, 17:36 GMT
Task Type Bug Report
Category Mirrors
Status Closed
Assigned To Christian Hesse (eworm)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description:
Latest ArchLinux 2022.01.01 will only EFI boot manually in EFI Shell using "Shell> FS1:\EFI\BOOT\BOOTx64.EFI" (on Virtualbox).
* Source: http://ftp.nluug.nl/os/Linux/distr/archlinux/iso/2022.01.01/archlinux-2022.01.01-x86_64.iso
* SHA1 hash: efc9c33087e756ba1c7f326e67bfaa685eb51be3 archlinux-2022.01.01-x86_64.iso

Steps to reproduce:
* Virtual Box: Windows Version 6.1.30 r148432 (Qt5.6.2)
* Chipset: PIIX3
* Enable I/O APIC
* Enable EFI
* CDROM Controller IDE/PIIX4


This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 01 February 2022, 17:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with installation medium 2022.02.01
Comment by Joseph (boocheus) - Sunday, 02 January 2022, 00:38 GMT
I can confirm I was pulling my hair out trying to figure out the issue. Quite a severe issue. I cant even get backslash to work on my EFI shell.
Comment by Pierre Schmitz (Pierre) - Sunday, 02 January 2022, 12:26 GMT
Just for the record: it does boot fine on real hardware though.
Comment by nl6720 (nl6720) - Monday, 03 January 2022, 10:55 GMT
The description of this bug was lacking in details. It made me think that systemd-boot doesn't launch at all and VirtualBox's firmware dumps you into the UEFI shell.

After trying it, systemd-boot launches fine, but only shows the automatically generated boot entries (EFI Shell and Reboot Into Firmware Interface). The manual boot entries (from loader/entries/) are missing.
This appears to be a systemd bug introduced in v250.
Comment by Magnus (DeArchDev) - Saturday, 08 January 2022, 17:26 GMT
You might want to try to downgrade systemd to the previous version(this might be a upstream bug instead of an arch one) and see if that solves the problem
Comment by nl6720 (nl6720) - Sunday, 09 January 2022, 09:43 GMT
If you want to test, you can try https://gitlab.archlinux.org/nl6720/archiso/-/jobs/43137/artifacts/raw/output/archlinux-2022.01.03-x86_64.iso which uses systemd-bootx64.efi from systemd-249.7-2.

Someone should report this regression to the systemd project: https://github.com/systemd/systemd/issues
Comment by Magnus (DeArchDev) - Sunday, 09 January 2022, 14:02 GMT
I recommend closing this issue and instead posting it to systemd's issue page as this is a upstream bug and not a one related to archlinux(and the arch team can't do anything about this one). The comment above me seems to have posted a fix for this issue which might work.
Comment by Jan (medhefgo) - Monday, 10 January 2022, 15:07 GMT
This one is on VirtualBox violating the EFI spec. See https://github.com/systemd/systemd/pull/22074 for the fix.

But really, you shouldn't use VirtualBox these days. On Linux just use QEMU (libvirt/virt-manager) and on windows you're best option is Hyper-V (unless you don't mind launching/managing QEMU yourself).
Comment by Shivanand (shivanandvp) - Monday, 10 January 2022, 15:18 GMT
Thanks @Jan
Comment by Jilles Groenendijk (jilles_com) - Monday, 10 January 2022, 18:26 GMT
Thanks @Jan for fixing fixing others being non-compliant and totally agree on using QEMU or Hyper-V!
Comment by Joseph (boocheus) - Monday, 10 January 2022, 18:51 GMT
Unfortunately, those on windows home basic do not have the luxury of hyper-v. So this is all I have for now.
Comment by Christian Hesse (eworm) - Tuesday, 11 January 2022, 09:43 GMT
Cherry-picked in systemd 250.2-2...
Comment by Christian Hesse (eworm) - Tuesday, 11 January 2022, 09:44 GMT
Next ISO should be fine...
Is everybody ok closing this now?
Comment by Magnus (DeArchDev) - Tuesday, 11 January 2022, 12:14 GMT
@Joseph, you can use QtEmu which is a gui frontend to qemu(this makes it a bit more easier to manage and launch qemu virtual machines. This is if you want to use qemu on windows, although it seems that the issue has been fixed so if you want to use virtualbox, you should be able to do it now)
Comment by Joseph (boocheus) - Tuesday, 11 January 2022, 15:18 GMT
@Magnus Getting this error when booting from arch iso "This kernel requires an x86-64 CPU, but only detected an i686 CPU."
Comment by Magnus (DeArchDev) - Tuesday, 11 January 2022, 16:08 GMT
@Joseph, did you get that error when launching it from QtEmu or from virtualbox?
Comment by Joseph (boocheus) - Tuesday, 11 January 2022, 16:27 GMT
@Magnus sorry forgot to specify. It was QtEmu.
Comment by Magnus (DeArchDev) - Tuesday, 11 January 2022, 16:40 GMT
This is the link to qtemu(https://gitlab.com/qtemu, you would have to clone it and run the script which is in the 'installer' folder). The github and sourceforge link in the website are the links which lead to the original qtemu which isn't being actively developed since 2009. The current one which is being maintained is a fork of that project(this fork is also mentioned in the official website).
Comment by Magnus (DeArchDev) - Tuesday, 11 January 2022, 17:00 GMT
EDIT : Do not clone installer, clone gui(sorry, I had misread the README) or download a zip from the releases(https://gitlab.com/qtemu/gui/-/releases#2.1). After that, open the README, there are links which lead to the windows installation
Comment by Joseph (boocheus) - Tuesday, 11 January 2022, 17:06 GMT
@magnus I have downloaded qemu and installed twice. qtemu is giving me the error that it cannot find qemu-img.
I cannot find it either.
Comment by Magnus (DeArchDev) - Tuesday, 11 January 2022, 17:43 GMT
@Joseph, sorry I had misread the installation instructions. ' Do not clone installer, clone gui(sorry, I had misread the README) or download a zip from the releases(https://gitlab.com/qtemu/gui/-/releases#2.1). After that, open the README, there are links which lead to the windows installation', I had written this comment afterwards. Also, I just checked in virtualbox, and it does have an kvm option in acceleration which should work well with linux distros(qemu actually uses some kvm features to run vms). And also, if you have any further problems, you should probably open a new forum discussion and discuss about it there as it seems like a closure request has been requested for this issue. EDIT : Now, I think that you should probably stick with virtualbox on windows as setting up qtemu is a bit of a pain, especially making it launch.
Comment by Joseph (boocheus) - Tuesday, 11 January 2022, 18:11 GMT
@magnus alright. Thanks. I do plan to stick to VirtualBox while on windows, I personally won't need serious vm performance until I am on Linux again anyway.
It certainly has been a pain to try and get qemu to work on windows as compared to Linux is a breeze. I think this thread can end here now.

Loading...