Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7313 - rtc errors

Attached to Project: Arch Linux
Opened by Börje Holmberg (linfan) - Wednesday, 30 May 2007, 21:21 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 02 June 2007, 07:14 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture i686
Severity Medium
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

With the kernel 2.6.21 I have started to get error msgs upon bootup as to rtc.

modprobe rtc gives:


FATAL: Error inserting rtc (/lib/modules/2.6.21-ARCH/kernel/drivers/char/rtc.ko): Input/output error

modprobe snd-rtctimer gives:
FATAL: Error inserting rtc (/lib/modules/2.6.21-ARCH/kernel/drivers/char/rtc.ko): Input/output error
[root@sawernew borje4]# modprobe snd-rtctimer
WARNING: Error inserting rtc (/lib/modules/2.6.21-ARCH/kernel/drivers/char/rtc.ko): Input/output error
FATAL: Error inserting snd_rtctimer (/lib/modules/2.6.21-ARCH/kernel/sound/core/snd-rtctimer.ko): Unknown symbol in module, or unknown parameter (see dmesg)

dmesg says:
rtc: I/O resource 70 is not free.
snd_rtctimer: Unknown symbol rtc_register
snd_rtctimer: Unknown symbol rtc_unregister
snd_rtctimer: Unknown symbol rtc_control
eth0: no IPv6 routers present
Linux agpgart interface v0.102 (c) Dave Jones
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt Link [APC3] enabled at IRQ 18
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [APC3] -> GSI 18 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:01:00.0 to 64
NVRM: loading NVIDIA UNIX x86 Kernel Module 1.0-9755 Mon Feb 26 23:21:15 PST 2007
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
rtc: I/O resource 70 is not free.
snd_rtctimer: Unknown symbol rtc_register
snd_rtctimer: Unknown symbol rtc_unregister
snd_rtctimer: Unknown symbol rtc_control

I have sound blaster live (emu10k1)








This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 02 June 2007, 07:14 GMT
Reason for closing:  Not a bug
Comment by Tobias Powalowski (tpowa) - Wednesday, 30 May 2007, 21:40 GMT
how about load the module you want to have?
rtc is old char device, new rtc subsystem is loaded by udev by default
Comment by Börje Holmberg (linfan) - Thursday, 31 May 2007, 05:56 GMT
???

Linfan
Comment by Tobias Powalowski (tpowa) - Thursday, 31 May 2007, 07:07 GMT
blacklist rtc module or just remove it from rc.conf

Loading...