Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73083 - [tigervnc] libvnc.so segfaults xorg-server >=21.1

Attached to Project: Community Packages
Opened by Ronnie Soak (Chaos99) - Saturday, 18 December 2021, 20:00 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 18 December 2021, 20:24 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The current tigervnc package leads to a seg fault on X11 startup when trying to load the libvnc.so module.

from /var/log/Xorg.0.log
[ 70.289] (II) LoadModule: "vnc"
[ 70.290] (II) Loading /usr/lib/xorg/modules/extensions/libvnc.so
[ 70.295] (II) Module vnc: vendor="TigerVNC Project"
[ 70.295] compiled for 1.20.9, module version = 1.0.0
[ 70.295] Module class: X.Org Server Extension
[ 70.295] ABI class: X.Org Server Extension, version 10.0
[...]
[ 71.019] (EE)
[ 71.019] (EE) Backtrace:
[ 71.019] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x89) [0x558703876099]
[ 71.019] (EE) 1: /usr/lib/Xorg (0x558703726000+0x15aeb9) [0x558703880eb9]
[ 71.019] (EE) 2: /usr/lib/libpthread.so.0 (0x7f071dc99000+0x13870) [0x7f071dcac870]
[ 71.019] (EE) 3: /usr/lib/Xorg (xf86OptionValue+0xb) [0x55870388d41b]
[ 71.019] (EE) 4: /usr/lib/xorg/modules/extensions/libvnc.so (0x7f071d11b000+0x34c11) [0x7f071d14fc11]
[ 71.019] (EE) 5: /usr/lib/Xorg (InitExtensions+0x89) [0x55870376ed69]
[ 71.019] (EE) 6: /usr/lib/Xorg (0x558703726000+0x3c39b) [0x55870376239b]
[ 71.019] (EE) 7: /usr/lib/libc.so.6 (__libc_start_main+0xd5) [0x7f071daefb25]
[ 71.019] (EE) 8: /usr/lib/Xorg (_start+0x2e) [0x55870376379e]
[ 71.019] (EE)
[ 71.019] (EE) Segmentation fault at address 0x100000011
[ 71.019] (EE)
Fatal server error:
[ 71.019] (EE) Caught signal 11 (Segmentation fault). Server aborting

The problem is known and allegedly fixed in the upstream repo, but no new release has been done yet.

Additional info:
* package version(s)
tigervnc 1.12.0-1
xorg-server 21.1.2-0

* config and/or log files etc.
#/etc/X11/xorg.conf.d/10-vnc.conf
Section "Module"
Load "vnc"
EndSection

Section "Screen"
Identifier "Screen0"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/root/.vnc/passwd"
EndSection


* link to upstream bug report, if any
https://github.com/TigerVNC/tigervnc/issues/1373

Steps to reproduce:
Update xorg-server, install tigervnc via pacman
Create config file listed above
Restart machine
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 18 December 2021, 20:24 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Please don't file duplicates

Loading...