Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#73063 - [cgal] incompatible with oneTBB

Attached to Project: Community Packages
Opened by bartus (bartus) - Friday, 17 December 2021, 13:48 GMT
Last edited by Antonio Rojas (arojas) - Friday, 17 December 2021, 17:31 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: `cgal:4.14.3` is not compatible with new `oneTBB` API

Mainly it references dropped `tbb::atomic` in those files:

usr/include/CGAL/thread.h
usr/include/CGAL/Spatial_lock_grid_3.h
usr/include/CGAL/Profile_counter.h
usr/include/CGAL/Polygon_mesh_processing/distance.h
usr/include/CGAL/Mesh_vertex_base_3.h
usr/include/CGAL/Mesh_cell_base_3.h
usr/include/CGAL/Mesh_3/vertex_perturbation.h
usr/include/CGAL/Mesh_3/Worksharing_data_structures.h
usr/include/CGAL/Mesh_3/Mesh_surface_cell_base_3.h
usr/include/CGAL/Mesh_3/Mesh_global_optimizer.h
usr/include/CGAL/Mesh_3/Mesh_complex_3_in_triangulation_3_base.h
usr/include/CGAL/Compact_mesh_cell_base_3.h

It's currently fixed in `cgal:5.3.1` those this package needs to be updated on oneTBB patch backported.

Relevent PR: https://github.com/CGAL/cgal/pull/5850
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 17 December 2021, 17:31 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Friday, 17 December 2021, 14:41 GMT
our cgal package is not built with tbb support, so what is the issue?
Comment by bartus (bartus) - Friday, 17 December 2021, 16:57 GMT
Yep, found a bug in `cloudcompare` instead which sets `CGLA_LINKED_WITH_TBB` arbitrally when `tbb` is found, btw. any chance for `cgal:5.3` update?

Loading...