Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72990 - [python-pip] ModuleNotFoundError: No module named 'pip._vendor.retrying'

Attached to Project: Arch Linux
Opened by Klaus Frank (agowa338) - Monday, 13 December 2021, 03:22 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 15 February 2022, 11:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description: `ModuleNotFoundError: No module named 'pip._vendor.retrying'` on newly installed ArchLinux Server.


Additional info:
* package version(s): 20.3.4-4
* link to upstream bug report, if any: https://github.com/pypa/pip/issues/6261


Steps to reproduce:
Run `pacman -S python python-pip` followed by just `pip`.


Full error:
```
Traceback (most recent call last):
File "/usr/bin/pip", line 33, in <module>
sys.exit(load_entry_point('pip==20.3.4', 'console_scripts', 'pip')())
File "/usr/bin/pip", line 25, in importlib_load_entry_point
return next(matches).load()
File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 162, in load
module = import_module(match.group('module'))
File "/usr/lib/python3.10/importlib/__init__.py", line 126, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 883, in exec_module
File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
File "/usr/lib/python3.10/site-packages/pip/_internal/cli/main.py", line 10, in <module>
from pip._internal.cli.autocompletion import autocomplete
File "/usr/lib/python3.10/site-packages/pip/_internal/cli/autocompletion.py", line 9, in <module>
from pip._internal.cli.main_parser import create_main_parser
File "/usr/lib/python3.10/site-packages/pip/_internal/cli/main_parser.py", line 7, in <module>
from pip._internal.cli import cmdoptions
File "/usr/lib/python3.10/site-packages/pip/_internal/cli/cmdoptions.py", line 25, in <module>
from pip._internal.cli.progress_bars import BAR_TYPES
File "/usr/lib/python3.10/site-packages/pip/_internal/cli/progress_bars.py", line 12, in <module>
from pip._internal.utils.logging import get_indentation
File "/usr/lib/python3.10/site-packages/pip/_internal/utils/logging.py", line 18, in <module>
from pip._internal.utils.misc import ensure_dir
File "/usr/lib/python3.10/site-packages/pip/_internal/utils/misc.py", line 26, in <module>
from pip._vendor.retrying import retry # type: ignore
ModuleNotFoundError: No module named 'pip._vendor.retrying'
```
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 15 February 2022, 11:54 GMT
Reason for closing:  Works for me
Comment by Antonio Rojas (arojas) - Monday, 13 December 2021, 06:44 GMT
what's the output of 'pacman -Qkk python-pip' and 'pacman -Qkk python-retrying'?
Comment by Klaus Frank (agowa338) - Monday, 13 December 2021, 11:01 GMT
`pacman -Qkk python-pip`:
```
python-pip: 350 total files, 0 altered files
```

`pacman -Qkk python-retrying`:
```
python-retrying: 14 total files, 0 altered files
```
Comment by Antonio Rojas (arojas) - Monday, 13 December 2021, 17:38 GMT
which version of python-retrying? And what is the output of

python -c "import retrying; print(retrying.__file__)"

?
Comment by Klaus Frank (agowa338) - Monday, 13 December 2021, 19:22 GMT
`/usr/lib/python3.10/site-packages/retrying.py`
Comment by Magnus (DeArchDev) - Saturday, 12 February 2022, 10:43 GMT
@Klaus Frank, can you tell if the issue has been fixed for you or is still present?
Comment by Klaus Frank (agowa338) - Saturday, 12 February 2022, 21:09 GMT
looks like it's working again.

Loading...