Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72974 - [alsa-ucm-conf] Symlink path mismatch

Attached to Project: Arch Linux
Opened by sekret (sekret) - Friday, 10 December 2021, 23:08 GMT
Last edited by David Runge (dvzrv) - Saturday, 11 December 2021, 11:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

One part of my system update script is the command

pacman -Qkk | grep ^error

Since the update of alsa-ucm-conf from version 1.2.5.1-1 to 1.2.6.2-2 I get this line as part of this command:

warning: alsa-ucm-conf: /usr/share/alsa/ucm2/conf.d/simple-card/Librem 5 Devkit.conf (Symlink path mismatch)

I'm not sure what this warning means. Could be it's a bug in pacman, because the symlink seems to work correctly:

# cat /usr/share/alsa/ucm2/conf.d/simple-card/Librem\ 5\ Devkit.conf
Syntax 2

SectionUseCase."HiFi" {
File "HiFi.conf"
}

Additional info:
* package version(s)
alsa-ucm-conf 1.2.6.2-2
* config and/or log files etc.
-
* link to upstream bug report, if any
-

Steps to reproduce:
Update the system or install alsa-ucm-conf and run the command pacman -Qkk | grep ^error
This task depends upon

Closed by  David Runge (dvzrv)
Saturday, 11 December 2021, 11:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  A problem with how pacman decodes spaces in symlink names has been identified and is now tracked in  FS#72978 

The reported issue does not seem to affect operation, however the warning will be addressed in an future pacman release.
Comment by Allan McRae (Allan) - Saturday, 11 December 2021, 11:22 GMT
Spot the difference....

$ pacman -Qkk alsa-ucm-conf
warning: alsa-ucm-conf: /usr/share/alsa/ucm2/conf.d/simple-card/Librem 5 Devkit.conf (Symlink path mismatch)
alsa-ucm-conf: 422 total files, 1 altered file

$ zgrep /usr/share/alsa/ucm2/conf.d/simple-card/Librem /var/lib/pacman/local/alsa-ucm-conf-1.2.6.2-2/mtree
./usr/share/alsa/ucm2/conf.d/simple-card/Librem\0405\040Devkit.conf time=1639157907.0 mode=777 type=link link=../../NXP/iMX8/Librem_5_Devkit/Librem\0405\040Devkit.conf

$ ls -l /usr/share/alsa/ucm2/conf.d/simple-card/Librem\ 5\ Devkit.conf
lrwxrwxrwx 1 root root 51 Dec 11 03:38 '/usr/share/alsa/ucm2/conf.d/simple-card/Librem 5 Devkit.conf' -> '../../NXP/iMX8/Librem_5_Devkit/Librem 5 Devkit.conf'


Seems libarchive encodes spaces when making the mtree file, pacman does not decode them
Comment by David Runge (dvzrv) - Saturday, 11 December 2021, 11:39 GMT
@Allan: Thanks for the clarification! :)

I will close this issue in favor of  FS#72978 .

Loading...