Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72949 - [gnome-control-center] freezes; no way to configure Gnome

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Wednesday, 08 December 2021, 00:06 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 10 December 2021, 07:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
gnome-control-center freezes and shows no window. No configuration options (e.g. Bluetooth) work right now.
Tried: 41.2-1, 41.1-2, 40.0-1: They all freeze. ā€”> The root cause is outside gnome-control-center. Iā€™m pretty sure that at least 41.1-2 and 40.0-1 (and maybe also 41.2-1) worked perfectly fine a few days ago.

Additional info:

* package version(s)
41.2-1, 41.1-2, 40.0-1 ā€” all of them freeze. Not sure what other packages to check.

* config and/or log files etc.
strace -f on 41.2.-1: https://paste.ee/p/bQ0um

Console output (which is probably just usual benign BS; not sure):
(gnome-control-center:9224): GStreamer-WARNING **: 22:05:25.706: External plugin loader failed. This most likely means that the plugin loader helper binary was not found or could not be run. You might need to set the GST_PLUGIN_SCANNER environment variable if your setup is unusual. This should normally not be required though.

* link to upstream bug report, if any N/A

Steps to reproduce:
Try to start gnome-control-center.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 10 December 2021, 07:48 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Thursday, 09 December 2021, 10:03 GMT
/usr/lib/gstreamer-1.0/gst-plugin-scanner doesn't exist?
Comment by Andrej Podzimek (andrej) - Friday, 10 December 2021, 00:45 GMT
Thank you so much for spotting that! Yes, that was the problem.

Loading...