Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72948 - [gnome-control-center] 41.1-2 works, 41.2-1 freezes

Attached to Project: Arch Linux
Opened by Andrej Podzimek (andrej) - Wednesday, 08 December 2021, 00:05 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 09 December 2021, 09:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
gnome-control-center freezes and shows no window. No configuration options (e.g. Bluetooth) work right now.
Tried: 41.2-1, 41.1-2, 40.0-1: They all freeze. ā€”> The root cause is outside gnome-control-center. Iā€™m pretty sure that at least 41.1-2 and 40.0-1 (and maybe also 41.2-1) worked perfectly fine a few days ago.

Additional info:

* package version(s)
41.2-1, 41.1-2, 40.0-1 ā€” all of them freeze. Not sure what other packages to check.

* config and/or log files etc.
strace -f on 41.2.-1: https://paste.ee/p/bQ0um

Console output (which is probably just usual benign BS; not sure):
(gnome-control-center:9224): GStreamer-WARNING **: 22:05:25.706: External plugin loader failed. This most likely means that the plugin loader helper binary was not found or could not be run. You might need to set the GST_PLUGIN_SCANNER environment variable if your setup is unusual. This should normally not be required though.

* link to upstream bug report, if any N/A

Steps to reproduce:
Try to start gnome-control-center.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 09 December 2021, 09:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Wrong title, based on a misunderstanding of how the PKGBUILD works. (What I had been trying to (re)build had been in fact the same latest version all over again.) This one is more accurate:  FS#72949 

Loading...