Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72927 - pango 1.50.0 assertion failures in e.g. leafpad and darktable (fixed in upstream)

Attached to Project: Arch Linux
Opened by Sakari Kapanen (flannelhead) - Sunday, 05 December 2021, 18:07 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 07 December 2021, 11:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: pango 1.50.0 shows several assertion failures with e.g. leafpad and darktable. The bug has been reported and fixed in upstream:
report: https://gitlab.gnome.org/GNOME/pango/-/issues/634
fix: https://gitlab.gnome.org/GNOME/pango/-/merge_requests/533

Relevant darktable bug report:
https://github.com/darktable-org/darktable/issues/10557
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 07 December 2021, 11:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  pango 1.50.0-2
Comment by Andreas Radke (AndyRTR) - Sunday, 05 December 2021, 18:15 GMT
@heftig: see also report  FS#72917 
Comment by Jan Alexander Steffens (heftig) - Monday, 06 December 2021, 02:59 GMT
Should be fixed in 1.50.0-2
Comment by S├ębastien (yopyop) - Monday, 06 December 2021, 09:43 GMT
EDIT : I wrote nonsense. By the time I tested darktable in english instead of french, pango was already patched apparently, because when I went back to french it worked fine (and still does).

original message :
I can confirm for darktable. I use it in with the french translation and it crashes every time. I switched to english and apparently it works fine. I guess there is a relation with special characters.

Loading...