Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72913 - [spyder] Crashes on startup (python-spyder-kernels version not accepted)

Attached to Project: Community Packages
Opened by Gergely Tarsoly (tarsolyger) - Saturday, 04 December 2021, 04:41 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Sunday, 05 December 2021, 17:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Spyder crashes at startup, complaining about the version of the spyder-kernels module (required: <2.2.0,>=2.1.1 ; Arch ships 2.2.0).

Additional info:
* package version(s)
spyder 5.1.5-2
python-spyder-kernels 2.2.0-1
* config and/or log files etc.

Traceback (most recent call last):
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
ws.require(__requires__)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 777, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (spyder-kernels 2.2.0 (/usr/lib/python3.9/site-packages), Requirement.parse('spyder-kernels<2.2.0,>=2.1.1'), {'spyder'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/usr/bin/spyder", line 33, in <module>
sys.exit(load_entry_point('spyder==5.1.5', 'gui_scripts', 'spyder')())
File "/usr/bin/spyder", line 25, in importlib_load_entry_point
return next(matches).load()
File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
module = import_module(match.group('module'))
File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 850, in exec_module
File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
File "/usr/lib/python3.9/site-packages/spyder/app/start.py", line 47, in <module>
from spyder.utils.external import lockfile
File "/usr/lib/python3.9/site-packages/spyder/utils/external/lockfile.py", line 31, in <module>
from spyder.utils.programs import is_spyder_process
File "/usr/lib/python3.9/site-packages/spyder/utils/programs.py", line 28, in <module>
import pkg_resources
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
def _initialize_master_working_set():
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
f(*args, **kwargs)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 570, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'spyder-kernels<2.2.0,>=2.1.1' distribution was not found and is required by spyder

* link to upstream bug report, if any

Steps to reproduce:
install spyder
start spyder from the terminal

Additional info: building the 2.2.0 spyder-kernels by modifying the PKGBUILD for python-spyder-kernels doesn't solve the issue, as once spyder stops complaining about the kernel version, the kernel complains about other packages.
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Sunday, 05 December 2021, 17:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Spyder was upgraded to 5.2 which fixes all issues.
Comment by Jonathon (jonathon) - Saturday, 04 December 2021, 11:36 GMT Comment by Laurent HOAREAU (laurent_waro) - Saturday, 04 December 2021, 12:32 GMT
Same problem for me...

Loading...