Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72911 - provides field for python-hid and python-hidapi conflicting packages

Attached to Project: Community Packages
Opened by jozef riha (jose1711) - Friday, 03 December 2021, 17:18 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 07 December 2021, 10:21 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Filipe LaĆ­ns (FFY00)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
At this point you cannot install a package depending on `python-hid` and then another package requiring `python-hidapi` due to a conflict. While it is possible to adjust a program to support both implementations user is still forced to choose between the two. I suggest there is a `provides` array added to both packages for cases when program is compatible with both modules.

Additional info:
* `python-hid` (community)
* `python-hidapi` (community)
This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 07 December 2021, 10:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  They do not provide the same API, they only occupy the same namespace.

Loading...